1023. Have Fun with Numbers (20)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

题目大意:

注意到数字123456789是一个9位数,有数字1到数字9组成,没有重复。我们将得到246913578,这恰好是另一个9为数字,只是排列顺序不同。如果我们再把他翻倍,看看结果如何!
现在您的任务是检查是否有更多的数字由此属性。也就是说给定一个K位数字加倍,你的任务是判断结果数字是否由原来的数字组成。
输入规格:
每个输入文件包含一个测试用例。每个测试用例包含一个不超过20位的正整数。
输出规范:
对于每个测试用例,如果加倍数字由原来的数字组成,那么打印“Yes”否则打印“No”然后再下一行打印出加倍的数字。

代码:

#include<stdio.h>
#include<string.h>
int main()
{
    int i,j,n,m,k,t,flag=0;
    char str[21],result[30];
    int arr[10],brr[10];
    memset(arr,0,sizeof(arr));
    memset(brr,0,sizeof(arr));
    scanf("%s",str);
    for(i=0;str[i]!='\0';i++)
    {
        arr[str[i]-'0']++;
    }
    k=0;
    for(i=strlen(str)-1,j=0;i>=0;i--)
    {
       n=str[i]-'0';
       m=n*2;
       m+=k;
       k=m/10;
       result[j++]=m%10+'0';
    }
    if(k!=0)
    {
        result[j++]=k+'0';
    }
    result[j]='\0';
    for(i=0;result[i]!='\0';i++)
    {
        brr[result[i]-'0']++;
    }
    for(i=0;i<10;i++)
    {
        if(arr[i]!=brr[i])
            break;
    }
    if(i==10)
    {
        printf("Yes\n");
    }
    else
    {
        printf("No\n");
    }
    for(i=strlen(result)-1;i>=0;i--)
        printf("%c",result[i]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值