1039. Course List for Student (25)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题目大意:

浙江大学有40000名学生,开设2500门课程。现在给出了所有课程的学生名单,你的任务是为每个来查询的学生输出注册的课程列表。
输入规格:
每个输入文件包含一个测试用例。对于每个测试用例,第一行包含两个正整数:N(<=40000),代表查询课程的学生数量,K(<=2500)代表课程的总数。然后学生的姓名列表按如下格式给出(从1到K):对于每一门课程,在一行中给出课程索引i和注册学生的数量Ni(<=200)。然后再下一行,给出Ni个学生的名字。一个学生名字包含3个大写的英文字母加上一个一位数字。最后一行包含前来查询的N个学生的名字。一行中的所有名字用空格隔开。
输出规范:

对于每个测试用例,用N行打印结果。每一行对应一名学生,按如下格式打印:首先打印学生姓名,然后是学生注册的课程总数,最后按递增顺序打印所选课程的下标。查询结果必须以输入的顺序打印。一行中的所有数据必须有一个空格隔开,在行尾没有多余的空格。

注:此题不能用string类型,用的话会超时。

代码:

#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
struct node
{
    vector<int> course;
}student[180000];
int change(char c[])
{
    return (c[0]-'A')*26*26*10+(c[1]-'A')*26*10+(c[2]-'A')*10+c[3]-'0';
}
bool cmp(int a,int b)
{
    return a<b;
}
int main()
{
    int i,j,n,m,k,t,index;
    char name[5];
    scanf("%d %d",&n,&k);
    for(i=0;i<k;i++)
    {
        scanf("%d %d",&m,&t);
        for(j=0;j<t;j++)
        {
            scanf("%s",name);
            index=change(name);
            student[index].course.push_back(m);
        }
    }
    for(i=0;i<n;i++)
    {
        scanf("%s",name);
        index=change(name);
        sort(student[index].course.begin(),student[index].course.end(),cmp);
        printf("%s %d",name,student[index].course.size());
        for(j=0;j<student[index].course.size();j++)
        {
            printf(" %d",student[index].course[j]);
        }
        printf("\n");
    }
    return 0;
}

超时代码:


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<map>
#include<vector>
using namespace std;
map<string ,vector<int> > student;
vector<string> stud;
bool cmp(int a,int b)
{
    return a<b;
}
int main()
{
    int i,j,n,m,k,t;
    string s;
    char p[10];
    scanf("%d %d",&n,&k);
    for(i=1;i<=k;i++)
    {
        scanf("%d %d",&m,&t);
        for(j=0;j<t;j++)
        {
            scanf("%s",p);
            s=p;
            student[s].push_back(m);
        }
    }
    for(i=0;i<n;i++)
    {
        scanf("%s",p);
        s=p;
        stud.push_back(s);
    }
    for(i=0;i<n;i++)
    {
        s=stud[i];
        printf("%s %d",s.c_str(),student[s].size());
        sort(student[s].begin(),student[s].end(),cmp);
        for(j=0;j<student[s].size();j++)
        {
            printf(" %d",student[s][j]);
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值