1048. Find Coins (25)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output "No Solution" instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution

题目大意:

伊娃喜欢收集来自世界各地的硬币,包括一些其他的行星,比如火星。有一天她去了一个环球购物中心,那里可以用各种支付方式进行支付。但是,有一个特别的要求:每个帐单只能用两个硬币来支付。因为她有多达10的5次方个硬币,他的确需要你的帮助。你应该告诉她,无论多少钱,他是否可以找到两个硬币来支付。
输入规格:
每个输入文件包含一个测试用例。对于每种情况,第一行包含两个正整数N(<=10的5次方,代表硬币的总数)和M(<=10的3次方,伊娃必须支付的金额)。第二行包含了N个面值的硬币,他们都是面值不超过500的硬币。直线上的所有数字用空格给隔开。
输出规范:
对于每个测试用例,在一行中打印两张面值为V1和V2(有空格隔开)的硬币,这样V1+V2=M和V1<=V2。如果这样的就过不是唯一的,那么输出V1最小的那个结果。如果没有解决方案,则输出“No Solution”。

代码:

#include<stdio.h>
#include<stdlib.h>
int arr[100001];
int cmp(const void *a,const void *b)
{
    return *(int *)a>*(int *)b?1:-1;
}
int main()
{
    int i,j,n,m,k,t;
    scanf("%d %d",&n,&m);
    for(i=0;i<n;i++)
    {
        scanf("%d",&arr[i]);
    }
    qsort(arr,n,sizeof(arr[0]),cmp);
    for(i=0,j=n-1;i<j;)
    {
        if(arr[i]+arr[j]>m)
        {
            j--;
        }
        else if(arr[i]+arr[j]<m)
        {
            i++;
        }
        else
        {
            printf("%d %d\n",arr[i],arr[j]);
          break;
        }
    }
    if(i>=j)
        printf("No Solution\n");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
#include <iostream>#include <cstdlib>using namespace std;struct Coin { int weight; // 硬币的重量 bool is_fake; // 是否为假币};Coin coins[100];// 将硬币分成两等份并比较的功能,返回较轻的那一半硬币的重量总和int balance(int start, int end) { int sum = 0; for (int i = start; i <= end; i++) { sum += coins[i].weight; } return sum;}int find_fake_coin(int start, int end) { int len = end - start + 1; if (len == 2) { // 只剩下两个硬币 if (coins[start].weight < coins[end].weight) { return start; } else { return end; } } else if (len == 3) { // 只剩下三个硬币 int index = rand() % 3 + start; if (index == start) { // 取出第一枚硬币作为样本 if (coins[start + 1].weight == coins[start + 2].weight) { return start; } else if (coins[start + 1].weight < coins[start + 2].weight) { return start + 1; } else { return start + 2; } } else if (index == start + 1) { // 取出第二枚硬币作为样本 if (coins[start].weight == coins[start + 2].weight) { return start + 1; } else if (coins[start].weight < coins[start + 2].weight) { return start; } else { return start + 2; } } else { // 取出第三枚硬币作为样本 if (coins[start].weight == coins[start + 1].weight) { return start + 2; } else if (coins[start].weight < coins[start + 1].weight) { return start; } else { return start + 1; } } } else { // 将硬币分成两等份并比较 int mid = (start + end) / 2; int left_sum = balance(start, mid); int right_sum = balance(mid + 1, end); if (left_sum < right_sum) { return find_fake_coin(start, mid); } else if (left_sum > right_sum) { return find_fake_coin(mid + 1, end); } else { return -1; // 不可能出现的情况 } }}int main() { int n; cout << "请输入硬币的数量n:"; cin >> n; srand(time(NULL)); int fake_index = rand() % n; // 随机生成假币的位置 for (int i = 0; i < n; i++) { coins[i].weight = 10; // 正常硬币的重量为10g if (i == fake_index) { coins[i].weight = 8; // 假币的重量为8g coins[i].is_fake = true; } else { coins[i].is_fake = false; } } int fake = find_fake_coin(0, n - 1); cout << "假币的位置是:" << fake << endl; return 0;}求此算法的运行结果和算法时间复杂度
06-08
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值