The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:
Itai nyan~ (It hurts, nyan~)Ninjin wa iyada nyan~ (I hate carrots, nyan~)Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".
Sample Input 1:3 Itai nyan~ Ninjin wa iyadanyan~ uhhh nyan~Sample Output 1:
nyan~Sample Input 2:
3 Itai! Ninjinnwaiyada T_T T_TSample Output 2:
nai
题目大意:
代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<string>
using namespace std;
char *suffix,input[300],tmp[300];
int main()
{
int i,j,n,m,k,t,tmplen,inputlen;
scanf("%d",&n);
getchar();
gets(tmp);
m=strlen(tmp);
suffix=tmp;
for(i=1;i<n;i++)
{
//printf("1\n");
gets(input);
tmplen=m-1;
inputlen=strlen(input)-1;
while(input[inputlen]==tmp[tmplen])
{
inputlen--;
tmplen--;
//printf("2");
}
if(tmplen==m-1)
{
suffix="nai";
break;
}
if(strlen(suffix)>m-tmplen-1)
{
suffix=tmp+tmplen+1;
}
}
printf("%s\n",suffix);
return 0;
}