1082. Read Number in Chinese (25)

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero ("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:
-123456789
Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu
Sample Input 2:
100800
Sample Output 2:
yi Shi Wan ling ba Bai

题目大意:


代码:

#include<stdio.h>
#include<stdlib.h>
char a[10][5]={"Shi","Bai","Qian","Wan","Shi","Bai","Qian","Yi"};
char c[11][5]={"ling","yi","er","san","si","wu","liu","qi","ba","jiu"};
int b[15],m,flag=0;
int main()
{
    int i,j,n,k,t,l=0;
    scanf("%d",&n);
    m=abs(n);
    if(n<0)
    {
        printf("Fu ");
    }
    if(m==0)
    {
        printf("ling");
    }
    while(m>0)
    {
        b[l++]=m%10;
        m/=10;
    }
    for(i=l-1;i>=0;i--)
    {
        for(j=i;j>=0;j--)
                if(b[j]!=0)
                break;
            if(j<0)
                break;
        if(b[i]==0)
        {
            if(i>3)
            {
               for(j=i;j>3;j--)
               {
                   if(b[j]!=0)
                    break;
               }
               i=j+1;
               if(j<=3)
               {
                  printf(" Wan");
               }
               else
               {
                   printf(" ling");
               }
            }
            else
            {
                for(j=i;j>=0;j--)
                {
                    if(b[j]!=0)
                    {
                        break;
                    }
                }
                if(j>=0)
                {

                  printf(" ling");
                }
                i=j+1;
            }
            continue;
        }
        if(i==l-1)
        {
            if(i-1>=0)
            printf("%s %s",c[b[i]],a[i-1]);
            else
            printf("%s",c[b[i]]);
        }
        else
        {
            if(i-1>=0)
            printf(" %s %s",c[b[i]],a[i-1]);
            else
            printf(" %s",c[b[i]]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值