In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
Your job is to tell if a given complete binary tree is a heap.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 100), the number of trees to be tested; and N (1 < N <= 1000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, print in a line "Max Heap" if it is a max heap, or "Min Heap" for a min heap, or "Not Heap" if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.
Sample Input:3 8 98 72 86 60 65 12 23 50 8 38 25 58 52 82 70 60 10 28 15 12 34 9 8 56Sample Output:
Max Heap 50 60 65 72 12 23 86 98 Min Heap 60 58 52 38 82 70 25 8 Not Heap 56 12 34 28 9 8 15 10
题目大意:
代码:
#include<stdio.h>
int a[1010],m,b[1010],num;
int MaxHeap()
{
int i,j,k;
for(i=0;i<m/2;i++)
{
if(i*2+1<m&&i*2+2<m)
{
k=i*2+1;
if(a[k]<a[i*2+2])
{
k=i*2+2;
}
}
else if(i*2+1<m&&i*2+2>=m)
{
k=i*2+1;
}
if(a[i]<a[k])
{
return 0;
}
}
return 1;
}
int MinHeap()
{
int i,j,k;
for(i=0;i<m/2;i++)
{
if(i*2+1<m&&i*2+2<m)
{
k=i*2+1;
if(a[k]>a[i*2+2])
{
k=i*2+2;
}
}
else if(i*2+1<m&&i*2+2>=m)
{
k=i*2+1;
}
if(a[i]>a[k])
{
return 0;
}
}
return 1;
}
void postorder(int root)
{
if(root<m)
{
postorder(root*2+1);
postorder(root*2+2);
b[num++]=a[root];
}
}
int main()
{
int i,j,n,k,t;
scanf("%d %d",&n,&m);
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
scanf("%d",&a[j]);
}
num=0;
postorder(0);
int flag1=MaxHeap();
if(flag1==1)
{
printf("Max Heap\n");
}
int flag2=MinHeap();
if(flag2==1)
{
printf("Min Heap\n");
}
if(flag1==0&&flag2==0)
{
printf("Not Heap\n");
}
for(j=0;j<m;j++)
{
if(j==0)
{
printf("%d",b[j]);
}
else
{
printf(" %d",b[j]);
}
}
printf("\n");
}
return 0;
}