1128. N Queens Puzzle (20)

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1, Q2, ..., QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

 
Figure 1
 
Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1 < K <= 200). Then K lines follow, each gives a configuration in the format "N Q1 Q2 ... QN", where 4 <= N <= 1000 and it is guaranteed that 1 <= Qi <= N for all i=1, ..., N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print "YES" in a line; or "NO" if not.

Sample Input:
4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4
Sample Output:
YES
NO
NO
YES

题目大意:


代码:

#include<stdio.h>
#include<string.h>
int a[1010][1010];
int main()
{
    int i,j,n,m,k,t,l1,l2;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&m);
        memset(a,0,sizeof(a));
        int flag=0;
        for(j=1;j<=m;j++)
        {

            scanf("%d",&k);
            if(flag==0)
            {
                for(l1=k,l2=j;l1>=1&&l2<=m;l1--,l2++)
                if(a[l1][l2]==1)
            {
                flag=1;
                break;
            }
            for(l1=k,l2=j;l1<=m&&l2>=1;l1++,l2--)
                if(a[l1][l2]==1)
            {
                flag=1;
                break;
            }
            for(l1=k,l2=j;l1>=1&&l2>=1;l1--,l2--)
                if(a[l1][l2]==1)
            {
                flag=1;
                break;
            }
            for(l1=k,l2=j;l1<=m&&l2<=m;l1++,l2++)
                if(a[l1][l2]==1)
            {
                flag=1;
                break;
            }
            for(l1=1;l1<=m;l1++)
            {
                if(a[k][l1])
                {
                   flag=1;
                   break;
                }
            }
            }
            if(flag==0)
            {
                a[k][j]=1;
            }
        }
        if(flag==0)
        {
            printf("YES\n");
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
当然,以下是加上注释后的代码: ```python class NQueens: # 初始化函数,接受一个整数n,表示棋盘的大小 def __init__(self, n): self.n = n self.board = [['.' for i in range(n)] for j in range(n)] # 用二维数组表示棋盘,初始值为'.' self.solutions = [] # 存储所有解决方案的列表 # 求解N皇后问题的函数,返回一个包含所有解决方案的列表 def solveNQueens(self): self.backtrack(0) # 从第0行开始回溯 return self.solutions # 回溯函数,尝试所有可能的解决方案 def backtrack(self, row): # 如果已经尝试了所有行,说明找到了一组解决方案 if row == self.n: self.solutions.append([''.join(row) for row in self.board]) # 将当前解决方案加入到列表中 return # 尝试在当前行的所有列中放置皇后 for col in range(self.n): if self.isValid(row, col): # 如果当前位置可以放置皇后 self.board[row][col] = 'Q' # 在当前位置放置皇后 self.backtrack(row + 1) # 继续往下一行回溯 self.board[row][col] = '.' # 回溯后,将皇后从当前位置移除 # 检查是否可以在给定的行和列放置皇后 def isValid(self, row, col): # 检查当前列是否已经有皇后 for i in range(row): if self.board[i][col] == 'Q': return False # 检查左上方是否有皇后 for i, j in zip(range(row-1, -1, -1), range(col-1, -1, -1)): if self.board[i][j] == 'Q': return False # 检查右上方是否有皇后 for i, j in zip(range(row-1, -1, -1), range(col+1, self.n)): if self.board[i][j] == 'Q': return False return True ``` 这份代码的注释包括:类的初始化函数、求解函数、回溯函数以及判断当前位置是否可以放置皇后的函数。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值