1123. Is It a Complete AVL Tree (30)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

    

    

Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print "YES" if the tree is complete, or "NO" if not.

Sample Input 1:
5
88 70 61 63 65
Sample Output 1:
70 63 88 61 65
YES
Sample Input 2:
8
88 70 61 96 120 90 65 68
Sample Output 2:
88 65 96 61 70 90 120 68
NO

题目大意:


代码:

#include<stdio.h>
#include<stdlib.h>
#include<queue>
using namespace std;
struct node
{
    int data;
    struct node *lchild,*rchild;
};
int n,cnt=0;
int getdeep(struct node *root)
{
    if(root==NULL)
    {
        return 0;
    }
    int l=getdeep(root->lchild);
    int r=getdeep(root->rchild);
    return l>r?l+1:r+1;
}
struct node *LL(struct node *root)
{
    struct node *tmp=root->lchild;
    root->lchild=tmp->rchild;
    tmp->rchild=root;
    return tmp;
}
struct node *RR(struct node *root)
{
    struct node *tmp=root->rchild;
    root->rchild=tmp->lchild;
    tmp->lchild=root;
    return tmp;
}
struct node *RL(struct node *root)
{
    root->rchild=LL(root->rchild);
    return RR(root);
}
struct node *LR(struct node *root)
{
    root->lchild=RR(root->lchild);
    return LL(root);
}
struct node * create(struct node *root,int value)
{
    if(root==NULL)
    {
        root=(struct node *)malloc(sizeof(struct node));
        root->data=value;
        root->lchild=root->rchild=NULL;
    }
    else if(value>root->data)
    {
        root->rchild=create(root->rchild,value);
        if(getdeep(root->rchild)-getdeep(root->lchild)==2)
        {
            if(value>root->rchild->data)
            {
                root=RR(root);
            }
            else
            {
                root=RL(root);
            }
        }
    }
    else
    {
        root->lchild=create(root->lchild,value);
        if(getdeep(root->lchild)-getdeep(root->rchild)==2)
        {
            if(value<root->lchild->data)
            {
                root=LL(root);
            }
            else
            {
                root=LR(root);
            }
        }
    }
    return root;
}
void preorder(struct node *root)
{
    if(root)
    {
       printf("%d ",root->data);
       preorder(root->lchild);
       preorder(root->rchild);
    }
}
void level(struct node *root)
{
    queue<struct node *> q;
    q.push(root);
    int flag=0;
    while(!q.empty())
    {
        struct node *tmp=q.front();
        q.pop();
        if(tmp!=NULL)
        {
            if(flag==0)
        {
            printf("%d",tmp->data);
            flag=1;
        }
        else
        {
            printf(" %d",tmp->data);
        }
            q.push(tmp->lchild);
            q.push(tmp->rchild);
        }
    }
}
void level1(struct node *root)
{
    queue<struct node *> q;
    q.push(root);
    while(!q.empty())
    {
        struct node *tmp=q.front();
        q.pop();
        if(tmp!=NULL)
            {
                q.push(tmp->lchild);
            q.push(tmp->rchild);
            }
            if(tmp==NULL)
                break;
            cnt++;
    }
}
int main()
{
    int i,j,m,k,t;
    struct node *root=NULL;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&m);
        root=create(root,m);
    }
    //preorder(root);
    level(root);
    printf("\n");
    level1(root);
    if(cnt==n)
    {
        printf("YES\n");
    }
    else
    {
        printf("NO\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值