1121. Damn Single (25)

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888

题目大意:


代码:

#include<stdio.h>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
map<int,int> Map1,Map2;
vector<int> v;
int main()
{
    int i,j,n,m,k,t;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d %d",&k,&t);
        Map1[k]=t;
        Map1[t]=k;
    }
    scanf("%d",&m);
    for(i=0;i<m;i++)
    {
        scanf("%d",&k);
        Map2[k]=1;
    }
    map<int,int>::iterator it;
    for(it=Map2.begin();it!=Map2.end();it++)
    {
        if(Map1.find(it->first)!=Map1.end())
        {
            if(Map2.find(Map1[it->first])==Map2.end())
            {
              v.push_back(it->first);
            }
        }
        else
        {
           v.push_back(it->first);
        }
    }
    sort(v.begin(),v.end());
    printf("%d\n",v.size());
    for(i=0;i<v.size();i++)
    {
        if(i==0)
        {
            printf("%05d",v[i]);
        }
        else
        {
            printf(" %05d",v[i]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值