1114. Family Property (25)

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 ... Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi's are the ID's of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

题目大意:


代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node
{
    int id,fatherid,motherid,M_estate,Area;
    int childid[20];
}family[1001];
struct node1
{
    int id,person;
    double M_estate,Area;
    int flag;
}answer[10001];
int F[10001];
int visited[100001];
bool cmp(struct node1 a,struct node1 b)
{
    if(a.Area!=b.Area)
        return a.Area>b.Area;
    else
        return a.id<b.id;
}
int find(int x)
{
    while(x!=F[x])
    {
        x=F[x];
    }
    return x;
}
void Union(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    {
        if(fx>fy)
        {
            F[fx]=fy;
        }
        else
        {
           F[fy]=fx;
        }
    }
}
int main()
{
    int i,j,n,m,k,t,cnt=0;
    for(i=0;i<10000;i++)
        F[i]=i;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d %d %d %d",&family[i].id,&family[i].fatherid,&family[i].motherid,&k);
        visited[family[i].id]=1;
        if(family[i].fatherid!=-1)
        {
            visited[family[i].fatherid]=1;
            Union(family[i].id,family[i].fatherid);
        }
        if(family[i].motherid!=-1)
        {
            visited[family[i].motherid]=1;
            Union(family[i].id,family[i].motherid);
        }
        for(j=0;j<k;j++)
        {
            scanf("%d",&family[i].childid[j]);
            visited[family[i].childid[j]]=1;
            Union(family[i].id,family[i].childid[j]);
        }
        scanf("%d %d",&family[i].M_estate,&family[i].Area);
    }
    for(i=0;i<n;i++)
    {
        int id=find(family[i].id);
        answer[id].id=id;
        answer[id].M_estate+=family[i].M_estate;
        answer[id].Area+=family[i].Area;
        answer[id].flag=1;
    }
    for(i=0;i<10000;i++)
    {
        if(visited[i]==1)
            answer[find(i)].person++;
        if(answer[i].flag==1)
            cnt++;
    }
    for(i=0;i<10000;i++) {
        if(answer[i].flag==1) {
            answer[i].M_estate = (double)(answer[i].M_estate * 1.0 / answer[i].person);
            answer[i].Area = (double)(answer[i].Area * 1.0 / answer[i].person);
        }
    }
    sort(answer,answer+10000,cmp);
    printf("%d\n", cnt);
    for(i=0;i<cnt;i++)
        printf("%04d %d %.3f %.3f\n",answer[i].id,answer[i].person,answer[i].M_estate,answer[i].Area);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值