大数相加的运算

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 453085    Accepted Submission(s): 87837

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

 

 

Sample Input

 

2 1 2 112233445566778899 998877665544332211

 

 

Sample Output

 

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

 

 

Author

Ignatius.L

 

 

Recommend

We have carefully selected several similar problems for you:  1004 1003 1008 1005 1009 

 

#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;

int vec1[100002];
int vec2[100002];
int vec[100002];

int main(){
	int n;
	cin>>n;
	for(int t=1;t<=n;t++){
		string s1;
		string s2;
		cin>>s1;
		cin>>s2;
		string s3=s1;
		string s4=s2;
		memset(vec1,0,sizeof(vec1));
		memset(vec2,0,sizeof(vec2));
		memset(vec,0,sizeof(vec));
		reverse(s1.begin(),s1.end());
		reverse(s2.begin(),s2.end());
		int l1=s1.length();
		int l2=s2.length();
		for(int i=0;i<l1;i++){
			vec1[i]=s1[i]-48;
		}
		for(int i=0;i<l2;i++){
			vec2[i]=s2[i]-48;
		} 
		int l= l1>l2? l1: l2;
		int nex=0;
		for(int i=0;i<l;i++){
			int ans=vec1[i]+vec2[i]+nex;
			vec[i]=ans%10;
			nex=ans/10;
		}
		if(nex!=0){
			vec[l++]=nex;	
		}
		if(t!=1){
			cout<<endl;
		}
		cout<<"Case "<<t<<":"<<endl;
		cout<<s3<<" + "<<s4<<" = ";
		for(int i=l-1;i>=0;i--){
			cout<<vec[i];
		}
		cout<<endl;
	} 
	
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值