hdu 1160 - FatMouse's Speed

9 篇文章 0 订阅

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 897 Accepted Submission(s): 460

Problem Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

 

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

 

Two mice may have the same weight, the same speed, or even the same weight and speed.

 

Output

            Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

 

W[m[1]] < W[m[2]] < ... < W[m[n]]

 

and 

 

S[m[1]] > S[m[2]] > ... > S[m[n]]

 

In order for the answer to be correct, n should be as large as possible.

All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

 

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

 

Sample Output

4
4
5
9
7

 

 

来自 <http://acm.hdu.edu.cn/game/entry/problem/show.php?chapterid=3&sectionid=2&problemid=4>

 

题意:所谓FatMouse就是觉得老鼠越胖,它就跑的越快,而想要推翻这个理论就必须找到这样一种序列,即老鼠越胖跑得越慢的序列,为了使推论更加精确,此序列越多越好,也许答案会有很多种,你只需找到其中一种

 

分析:其实就是个找最大子串的dp问题,只是比平常多加了个排序罢了,我们不妨设老鼠是一个类来进行操作。

 

代码:

#include<iostream>

#include<algorithm>

using namespace std;

 

typedef class  MICE

{

public:

int speed; //老鼠速度

intfat;        //老鼠体重

intlie;        //老鼠原来输入的位置

intcan;        //当前老鼠最大子串的存储

intfatherLie;                //该子串中前一个老鼠是谁

}Mice;

 

int howSort(Micea,Mice b)

{

returna.fat < b.fat;

}

 

int main()

{

Micemice[1000];

intqueue[1000];

intlen = 0,max = 1,sign;

while(cin>> mice[len].fat >> mice[len].speed)

{

mice[len].fatherLie= -1;

mice[len].can= 1;

mice[len].lie= len++;

}

sort(mice,mice+len,howSort);

for(inti = 1; i < len; i++)

{

inttemp = 10001;

for(intj = i-1; j >= 0; j--)

{

if(mice[i].fat== mice[j].fat) continue;

if(mice[i].speed>= mice[j].speed) continue;

if(mice[j].speed>= temp) continue;

if(mice[i].can< (mice[j].can + 1))

{

mice[i].can= mice[j].can + 1;

mice[i].fatherLie= j;

temp= mice[j].speed;

}

}

if(max> mice[i].can) continue;

max= mice[i].can;

sign= i;

}

cout<< max <<endl;

inti = sign,k = max;

while(mice[i].fatherLie!= -1)

{

queue[--k]= mice[i].lie + 1;

i= mice[i].fatherLie;

}

queue[--k]= mice[i].lie + 1;

for(inti = 0; i < max; i++)

cout<< queue[i] << endl;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值