ubuntu9.10 软件配置

转载 2010年05月25日 16:03:00

ubuntu9.10 我的个人软件配置(以备日后重装系统时快速恢复原来的配置)

1.先配置网络环境

vi /etc/resolve.conf

写入 nameserver 202.106.0.20

    nameserver 202.106.195.115

vi /etc/network/interface

写入:           

  1. inface eth0 inet  static   
  2. address 192.168.1.156  
  3. netmask 255.255.255.0  
  4. gateway 192.168.1.1  
  5. auto eth0  

/etc/init.d/networking restart

当可以ping通网关而不能上网时,大概是路由的问題,

route add default qw 192.168.0.254

2.更新源,然后 sudo apt-get update

3.中文桌面环境

  system->Administration->languate support   

  点  install

  注销,重新登录

4.中文输入法

   sudo apt-get remove ibus

   sudo apt-get install scim scim-chinese  scim-gtk2-immodule

   scim-tables-zh     

   注销,重新登录             

5.安装qemu

(1)通过sudo 解压build-root.tgz:    sudo tar -xf build-root.tgz

(2)需要qemu0.10.50版本

可以通过源安装:
在 /etc/apt/source.list 中加入下面这两个源,然后(必须)屏蔽其它的源,否则第三步不 成功.

deb http://download.opensuse.org/repositories/openSUSE:/Tools/Debian_5.0/ /                                                                                               
deb http://ftp.debian.org/debian/ stable main

         sudo apt-get update     这时须要下 载50M才对.

 

(3)第一次运行,qemu-binfmt-conf.sh

然后执行:sudo chroot build-root/ su abuild 进入编译环境

注:若update时出现公钥的问题,用以下的命令解决。 其中的XXXXX 为提示的编号
gpg --keyserver pgpkeys.mit.edu --recv-key  XXXXXX  && gpg -a --export XXXXXXX | sudo apt-key add -

6.安装飞信

       得先安装qt4:

        sudo apt-get  install libqt4-dev

        sudsudo apt-get  install qt4-doc

        sudo apt-get  install qt4-designer

        sudo apt-get  install qt4-qtconfig

        

下载飞信的deb包后,通过dpkg  -i 命令安装该包

7.安装飞鸽传书(转)

    sudo wget sudo wget http://www.ipmsg.org/archive/g2ipmsg-0.9.6.tar.gz

      sudo apt-get install gettext

      以下是飞鸽所依赖的gtk2.4的安装

    sudo apt-get install gnome-core-devel  #这将安装 libgtk2.0-dev libglib2.0-dev 等开发相关的库文件

    sudo apt-get install devhelp   #这将安装 devhelp GTK文档查看程序

     sudo apt-get install libglib2.0-doc libgtk2.0-doc #这将安装 gtk/glib 的API参考手册及其它帮助文档

    sudo apt-get install glade libglade2-dev #这将安装基于GTK的界面GTK是开发Gnome窗口 的c/c++语言图形库。

    apt-get install devhelp

     注:以下所说的GBK, 也可以是GB2312

下载:
http://www.blogjava.net/Files/bukebushuo/g2ipmsg_0.9.6.tar.gz2:从终端进入解压后的目录执行一下命令:
   2.1) ./configure --prefix=/usr --sysconfdir=/etc --enable-systray --with-ext-charcode=GBK
        注意:执行这个命令主要是查看有无关联库未安装,根据提示用apt-get进行安装
大多情况下会显示如下信息(部分):
...
No package 'libgnomeui-2.0' found
No package 'gtk+-2.0' found
No package 'glib-2.0' found
...
这时我们可以执行如下命令:
sudo apt-get install libgnomeui*
提示是否安装时,输入Y即可
WARNING: You need GStreamer-0.10 or later installed if you need ...
上面警告可以执行:
sudo apt-get install gstreamer*-dev
安装结束再来一次检查,反复进行,直到不再出现No package提示信息为止。
   2.2) sudo make
   2.3) sudo make install

注销,重新登录。
3: 我编译完后,飞鸽传书出现在菜单 应用程序->附件中
4:从菜单点击执行或者终端执行/usr/bin/g2ipmsg即可出现在托盘中
5:进入飞鸽,从菜单 设置->首选项中设置 字符编码的外部代号为GBK

然后关闭飞鸽,重新打开,就可以看见中文的飞鸽了。^..^.

8.安装VIM

sudo apt-get  install vim

9.安装星际译王

http://wiki.ubuntu.org.cn/Stardict

sudo sudo apt-get install stardict

10. kermit

     wget  ftp://kermit.columbia.edu/kermit/archives/cku211.tar.gz

    mkdir kermit

    tar -zxvf cku211.tar.gz  -C kermit/  #把解压后的文件放到这个目录下

    cd kermit

    make linux   #这时如果报error: ncurses.h: 没有该文件或目录的错误:sudo apt-get install libncurses5-dev

    mv wermit /usr/local/bin/kermit

将下面的配置些如~/.kermrc 文件中:

set line /dev/ttyS0   set speed 115200   set carrier-watch off   set handshake none   set flow-control none   robust   set file type bin   set file name lit   set rec pack 1000   set send pack 1000   set window 5   c  

切换 :按下Ctrl + / ,再按c 就跳回kermit。跳回串口控制,可以输入c,即connect命令。

发送文件:

kermit中输入connect后,跳到u-boot串口界面。

输入loadb 0x0c008000 回车

按下 ctrl + / ,再按c,切换到kermit。

输入命令 :send /home/zImage

kermit开始传送数据 了,并可以看到传送进度,发送完后,输入c,再回到u-boot界面,然后,再输入:go 0x0c008000

内核开始运行了

10.安装黑客备单词软件

http://www.verycd.com/groups/@g2214375/262279.topic

http://wiki.ubuntu.org.cn/Reciteword

http://reciteword.cosoft.org.cn/reciteword/index.html

我插一句:make 的时候可能报错:error: invalid conversion from ‘const char*’ to ‘gchar*’

解决:就把那行的str1 和str2 前面加上(char *);这样编译就能过,虽然警告多了一些。

11. man手册完善

  1. 1.添加库函数手册  
  2. ubuntu默认是没有安装c语言的库函数man手册的,所以你在man perror 和sendto之类的函数时会显示没有相关文档的问题,这个问题让我郁闷了我好久。解决方法:  
  3. sudo apt-get  install manpages-dev  
  4. 2.让man显示中文  
  5. ubuntu源里面已经包含了中文的man包,所以不用从其他地方down了,直接  
  6. sudo apt-get  install manpages-zh  
  7. 但是这样man默认显示的还不是中文,还需要以下两步  
  8. a.把中文man包转换成utf8格式的  
  9. 新建一个脚本文件  
  10. gedit t.sh  
  11. 把下面内容添加进去  
  12. #!/bin/bashcd /usr/share/man/zh_CN/for k in *docd $kfor i in *.gzdo j=`echo ${i%.gz}` gunzip $i iconv -f gb18030 -t utf8 $j >tmp mv tmp $j gzip $jdonecd ..done   
  13. 然后  
  14. sudo ./t  
  15. b.修改man默认的语言  
  16. sudo gedit /etc/manpath.config 把里面的所有的 /usr/share/man 改成 /usr/share/man/zh_CN  
  17. 保存后退出,然后你再试一下man ls  
  18. 3.让没有中文帮助的显示英文  
  19. 做 完上面第二部还不够,这时你再man 一下一些c语言函数(不要用printf,socket之类比较有名的函数,这些已经有中文帮助了)的时候就会发现 竟然没有帮助,而刚才明明在第一步已经安装了啊。这是因为你上面 把/usr/share/man 改成 /usr/share/man/zh_CN的操 作使man只在中文帮助中搜索,如果没有就直接放弃,因此还需要以下操作,才能让man在没有中文帮助的时候自动显示英文的帮助,如果英文的也没有,哪就 真的没有了。  
  20. sudo gedit /etc/manpath.config  
  21. 然后搜索你刚才改过的地方,然后在其后面添加同样的一行,只是后面的目录还用原来的/usr/share/man,比如在修改后的  
  22. MANPATH_MAP /bin          /usr/share/man/zh_CN  
  23. 再添加一行  
  24. MANPATH_MAP /bin          /usr/share/man  

12.GUI编辑器,我用的anjuta,  在新立得里面搜索:anjuta,然后选中搜到的结果安装即可。

      code:blocks 听说也不赖。还没用过。搜索code:blocks 安装。

13.EMACS

      http://blog.chinaunix.net/u/15586/article_94597.html


12.安装星像仪软件(待续)

13.安装虚拟DOS平台

使用ASP.NET加密口令

使用ASP.NET加密口令当我们在网站上建立数据库时,保护用户的信息安全是非常必要的。多数用户不愿意让别人知道自己的信息,同时网管也不想因为安全问题而丢失网站的信誉。无论对于谁,安全问题都是非常重要的...
  • denal
  • denal
  • 2003-01-31 11:38:00
  • 748

ubuntu9.10网络配置

auto lo iface lo inet loopback auto eth0 iface eth0 inet static #ip address 172.16.39.111 net...
  • goodmentc
  • goodmentc
  • 2014-06-15 00:34:25
  • 733

Ubuntu9.10中安装中文输入法[转]

我的电脑一直是Windows和Linux双系统,只不过最近把openSuse11.1换成了Ubuntu9.10,感觉后者要好用一些,并且论坛要活跃一些。但刚装好它就给我来了个下马威:系统没自带中文输入...
  • eagle_of_sky
  • eagle_of_sky
  • 2010-09-09 22:45:00
  • 974

Ubuntu9.10更换内核

1.下载内核源代码并解压,进入内核源码根目录2.配置内核 make config make oldconfig make menuconfig make xconfig ...
  • wangran1996
  • wangran1996
  • 2017-04-10 18:25:42
  • 101

Ubuntu9.10安装Qt环境

一、更新源 1、首先备份Ubuntu9.10源列表 sudo cp /etc/apt/sources.list /etc/apt/sources.list.backup 2、打开更新源列表 sud...
  • u010555444
  • u010555444
  • 2015-05-11 09:59:19
  • 239

解决Ubuntu9.10无法连接网络的问题

为了开发的便利,主要是直接在某个目录下修改好了源码,然后直接进入Linux环境下编译WindowsXP挂载在这个目录下的程序,省去VM Tools来回移动代码的麻烦.由于本人偷懒,直接采用JZ2440...
  • yangxiaozhu_xiaoyu
  • yangxiaozhu_xiaoyu
  • 2015-12-02 22:06:50
  • 550

ubuntu9.10下交插编译环境arm-linux-gcc的建立

这两天有时间就试着安装ubuntu系统学习一下,结果在网上google了一篇转载得不能再垃圾的文字了,后来找到了这位仁兄的,还比较科学。最近重新硬盘安装了ubuntu9.04并升级到9.10就重新建立...
  • ranruoyu1003
  • ranruoyu1003
  • 2010-04-20 16:54:00
  • 588

ubuntu9.10 下开通samba 服务

一. Ubuntu samba配置的安装:sudo apt-get install samba smbfs smbclient二. 创建共享目录:mkdir /home/tony/sharesodu ...
  • tony821224
  • tony821224
  • 2011-02-16 10:35:00
  • 1392

在ubuntu9.10下怎么安装Vmware Tools

vmware tools是虚拟机VMware Workstation自带的一款工具,它的作用就是使用户可以从物理主机直接往虚拟机里面拖文件。如果不安装它,我们是无法进行虚拟机和物理机之间的文件传输的,...
  • stephenbruce
  • stephenbruce
  • 2015-09-12 11:08:11
  • 1343

ubuntu环境下重新编译内核

由于调试内核、驱动或工作需要,有可能需要对ubuntu下的内核进行重新编译,本文对内核重新编译过程进行简单分析,在进行重新编译内核前你可以通过uname -a来确认你的linux系统的当前版本。 ...
  • zdf511391565
  • zdf511391565
  • 2014-01-20 09:39:04
  • 573
收藏助手
不良信息举报
您举报文章:ubuntu9.10 软件配置
举报原因:
原因补充:

(最多只允许输入30个字)