hihocode——#1497 : Queen Attack

http://hihocoder.com/problemset/problem/1497
时间限制: 10000ms
单点时限: 1000ms
内存限制: 256MB

描述

There are N queens in an infinite chessboard. We say two queens may attack each other if they are in the same vertical line, horizontal line or diagonal line even if there are other queens sitting between them.

Now given the positions of the queens, find out how many pairs may attack each other?

输入

The first line contains an integer N.

Then N lines follow. Each line contains 2 integers Ri and Ci indicating there is a queen in the Ri-th row and Ci-th column.  

No two queens share the same position.  

For 80% of the data, 1 <= N <= 1000

For 100% of the data, 1 <= N <= 100000, 0 <= Ri, Ci <= 1000000000

输出

One integer, the number of pairs may attack each other.

样例输入
5  
1 1  
2 2  
3 3   
1 3
3 1

样例输出

10


题意:给你很多皇后的坐标,问有多少对会互相攻击~~

思路:只要用4个map记录行列和两个斜边出现的次数就行~~


#include<bits/stdc++.h>
using namespace std;

map<int ,int > m1;
map<int ,int > m2;
map<int ,int > m3;
map<int ,int > m4;
typedef long long LL;
int main()
{
    int n;
    LL ans=0;
    scanf("%d",&n);
    for(int i=0; i<n; i++)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        ans+=m1[a];
        m1[a]++;
        ans+=m2[b];
        m2[b]++;
        ans+=m3[a+b];
        m3[a+b]++;
        ans+=m4[b-a];
        m4[b-a]++;
    }
    cout<<ans<<endl;
    return 0;
}
/*
5
1 1
2 2
3 3
1 3
3 1
*/


10
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值