安装libjpeg库



1.建立相关路径
以下这几个文件节点最好建全,不然会出错。这是因为在自动生成的Makefile中已经设置好了
这几个路径,make的时候会在这几个路径下装入相应的内容请查看经过./configure 后生成Makefile第12行-16行

[yangshi@SunplusAPP jpeg]$ mkdir ~/jpeg6
[yangshi@SunplusAPP jpeg]$ mkdir ~/jpeg6/include
[yangshi@SunplusAPP jpeg]$ kdirr ~/jpeg6/lib
[yangshi@SunplusAPP jpeg]$ mkdir ~/jpeg6/bin
[yangshi@SunplusAPP jpeg]$ mkdir ~/jpeg6/man
[yangshi@SunplusAPP jpeg]$ mkdir ~/jpeg6/man/man1
=================
如果上面的路径不全会出现类似如下的错误
/usr/bin/install: 无法创建一般文件~/jpeg/man/man1/cjpeg.1’: 没有那个文件或目录
make: *** [install] Error 1
=================

2.解压

下载jpegsrc.v6b.tar.gz
[yangshi@SunplusAPP jpeg]$ tar -xzf jpegsrc.v6b.tar.gz
[yangshi@SunplusAPP jpeg]$ cd jpeg-6b
[yangshi@SunplusAPP jpeg]$./configure CC=arm-linux-gcc --host=arm-unknown-linux --prefix=~/jpeg-6b/jpegl   --enable-shared  --enable-static
[yangshi@SunplusAPP jpeg]$ make
[yangshi@SunplusAPP jpeg]$ make install

========================================
[root@localhost jpeg-6b]# make
./libtool --mode=compile arm-linux-gcc -O2 -I. -c ./jcapimin.c
make: ./libtool: Command not found
make: *** [jcapimin.lo] Error 127
========================================

检查环境变量,看了一下,PATH里没有arm-linux-gcc所在的bin,加入看一下结果。还是报错如上。
搜索一下,看这个libtool是个什么东西。
=================================

官方下载地址

Libtool (1.5): 
ftp://ftp.gnu.org/gnu/libtool/

3 安装 Libtool

为编译 Libtool 做准备:

./configure --prefix=/usr

编译软件包:

make

要测试结果,请运行:make check 。

安装软件包:

make install Libtool的内容

GNU libtool 是一个通用库支持脚本,将使用动态库的复杂性隐藏在统一、可移植的接口中。

安装下列程序: libtool 和 libtoolize

安装下列库文件: libltdl.[a,so].

简短说明

libtool 提供通用的库编译支持。

libtoolize 提供了一种标准方式来将libtool支持加入到一个软件包。

libltdl隐藏 dlopening 库的复杂细节。

Libtool 安装依赖关系

Libtool 依赖于: Bash, Binutils, Coreutils, Diffutils, GCC, Glibc, Grep, Make, Sed.

===================================
http://ftp.gnu.org/gnu/libtool/ 
下载,

安装,在安装目录下
===
[root@localhost libtool-1.5.12]# ./libtool

*** Warning: inferring the mode of operation is deprecated.
*** Future versions of Libtool will require --mode=MODE be specified.
libtool: warning: cannot infer operation mode without MODE-ARGS
libtool: you must specify a MODE
Try `libtool --help' for more information.
看来还能用,但是
在jpeg-6b下又不找到命令,可能是环境变量的问题:
把这个目录放入PATH中看一下export PATH=$PWD:$PATH
还是错误

=====
[root@localhost jpeg-6b]# make
./libtool --mode=compile arm-linux-gcc -O2 -I. -c ./jcapimin.c
make: ./libtool: Command not found
make: *** [jcapimin.lo] Error 127
[root@localhost jpeg-6b]# ./libtool

-bash: ./libtool: 
没有这个文件或目录。只能在复制来了,看一下。

==================================jpeg目录==
[root@localhost jpeg-6b]# cp ../libtool-1.5.12/libtool ./

[root@localhost jpeg-6b]# ./libtool
*** Warning: inferring the mode of operation is deprecated.
*** Future versions of Libtool will require --mode=MODE be specified.
libtool: warning: cannot infer operation mode without MODE-ARGS
libtool: you must specify a MODE
Try `libtool --help' for more information.

=======================
再make看一下。


[root@localhost jpeg-6b]# make
./libtool --mode=compile arm-linux-gcc -O2 -I. -c ./jcapimin.c
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [jcapimin.lo] Error 1

=====================================
搜到一文章说======

有的机器上会出现下列错误:

libtool: compile: unable to infer tagged configuration

libtool: compile: specify a tag with `--tag'

这时检查一下libtool里的CC变量是否设置为arm-linux-gcc,如果不是,可以手工改过来,或者设置环境变量lt_compiler=arm-linux-gcc,重新配置一下。

 

4.将你建的库相应的文件下载到你的开发板中

lib  bin include man

展开阅读全文

没有更多推荐了,返回首页