HDU 1027 全排列 (STL_permution)

34 篇文章 0 订阅

题意:求1-n的按升序规则的第M个排列,如1243是N=4的第2个排列,1324是第3个,即第M小序列


Sample Input
  
  
6 4 11 8
 

Sample Output
  
  
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1000+10;
int a[maxn];
int main()
{
	int i,j,n,m;
	while(cin>>n>>m) {
		for(i=1;i<=n;i++) a[i-1]=i;
		do
		{
			if(--m==0) break;
		}while(next_permutation(a,a+n));
		for(i=0;i<n;i++) {
			if(i) cout<<" ";
			cout<<a[i];
		}
		cout<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值