HDU 1394&& ZOJ 1484 求最小的逆序数 (线段树)

19 篇文章 0 订阅
11 篇文章 0 订阅
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 


a1, a2, ..., an-1, an (where m = 0 - the initial seqence)  ----1
a2, a3, ..., an, a1 (where m = 1) -----2
a3, a4, ..., an, a1, a2 (where m = 2) -------3
...
an, a1, a2, ..., an-1 (where m = n-1) ------ n

求上面序列哪个序列的逆序数最少。。。


思路:用O(nlogn)复杂度求出最初逆序数后,就可以用O(1)的复杂度分别递推出其他解
线段树功能:update:单点增减 query:区间求和

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
const int maxn=5000+10;
using namespace std;
int c[maxn<<2];
int b[maxn];
void update(int p,int add,int l,int r,int rt)
{
	if(l==r) {
		c[rt]=1;
		return ;
	}
	int mid=(l+r)>>1;
	if(p<=mid) update(p,add,l,mid,rt<<1);
	else update(p,add,mid+1,r,rt<<1|1);
	c[rt]=c[rt<<1]+c[rt<<1|1];
}
int query(int ll,int rr,int l,int r,int rt)
{
	if(ll<=l&&rr>=r) {
		return c[rt];
	}
	int mid=(l+r)>>1;
	int ans=0;
	if(ll<=mid) ans+=query(ll,rr,l,mid,rt<<1);
	if(rr>mid) ans+=query(ll,rr,mid+1,r,rt<<1|1);
	return ans;
} 

int main()
{
	int n,i,j,ans,t,temp,Max;
	int num;
	while(scanf("%d",&n)!=EOF) {
		ans=0;
		t=0;
		memset(c,0,sizeof(c));
		for(i=1;i<=n;i++) {
			scanf("%d",&num);
			num++;
			b[i]=num;
			update(num,1,1,n,1);
			temp=query(1,num,1,n,1);
//			a[i]=temp;
			ans+=num-temp;
		}
		Max=ans;
		for(i=1;i<=n;i++) {
			ans=ans-b[i]-b[i]+1+n;
			Max=min(ans,Max);
		}
		printf("%d\n",Max);
	}
	return 0;
}















树状数组实现:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 5000 +10;
int c[N],n,a[N];

void add(int i,int x)
{
	while(i<=n) {
		c[i]+=x;
		i+=i&(-i);
	}
}

int sum(int i)
{
	int ans=0;
	while(i>0) {
		ans+=c[i];
		i-=i&(-i);
	}
	return ans;
}

int main()
{
	int i,j,ans,tem;
	while(scanf("%d",&n)!=EOF) {
		memset(c,0,sizeof(c));
		ans=0;
		for(i=1;i<=n;i++) {
			scanf("%d",&a[i]);
			a[i]++;
		}
		for(i=1;i<=n;i++) {
			ans+=a[i]-1;
			ans-=sum(a[i]);
			add(a[i],1);
		}
		tem=ans;
//		printf("%d\n",ans);
		for(i=1;i<n;i++) {
			tem+=n-2*a[i]+1;
			ans=min(ans,tem);
		}
		printf("%d\n",ans);
	}
	return 0;
}









  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值