HDU 1051 二维排序安排时间 (贪心||STL_set 水过)

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 



题目大意:

给n根木棍的长度和重量。根据要求求出制作木棍的最短时间。建立第一个木棍需要1分钟,若是接着要制作的木棍重量和长度都比此木棍长就不需要建立的时间,若是没有,则再需要建立时间。求时间最小为多少

先将一维的顺序固定,在贪心安排第二维的时间。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>
using namespace std;
set<int>ss;
set<int>::iterator it;

struct node
{
	int l,w;
}a[55555];

bool cmp(node t1,node t2)
{
	if(t1.l<t2.l) return true;
	else if(t1.l==t2.l && t1.w<t2.w) return true;
	return false;
}

int main()
{
  
	int t,n,i,j;
	scanf("%d",&t);
//	cin>>t;
	while(t--) {
		scanf("%d",&n);
		ss.clear();
		for(i=1;i<=n;i++) scanf("%d%d",&a[i].l,&a[i].w);
		sort(a+1,a+1+n,cmp);
		ss.insert(a[1].w);
		for(i=2;i<=n;i++) {
			it=upper_bound(ss.begin(),ss.end(),a[i].w);
			if(it==ss.begin()) {
				ss.insert(a[i].w);
				continue;
			}
			it--;
			ss.erase(*it);
			ss.insert(a[i].w);
		}
		printf("%d\n",ss.size());
	}
	return 0;
} 



贪心

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

struct stick
{
    int l;
    int w;
}s[5000];

bool cmp(stick a,stick b)
{
    if(a.l<b.l)
        return true;
    else if(a.l>b.l)
        return false;
    else
        return a.w<b.w;
}

int main()
{
    int t,n,minute,ti,number;
    int mark[5000];
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=0;i<n;i++)
            cin>>s[i].l>>s[i].w;
        sort(s,s+n,cmp);
        memset(mark,0,sizeof(mark));
        number=0;
        minute=0;
        int pl;
        while(number!=n)
        {
            for(int i=0;i<n;i++)
                if(!mark[i])
                {
                    pl=i;
                    minute++;
                    break;
                }
            for(int i=0;i<n;i++)
            {
                if(!mark[i]&&s[i].l>=s[pl].l&&s[i].w>=s[pl].w)
                {
                    mark[i]=1;
                    number++;
                    pl=i;
                }
            }
        }
        cout<<minute<<endl;
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值