HUST 1602 (找规律)


Description

This problem is quiet easy. 
Initially, there is a string A. 
  
Then we do the following process infinity times. 
 A := A +   “HUSTACM” + A 
  
For example, if a = “X”, then 
After 1 step, A will become   “XHUSTACMX”
After 2 steps, A will become   “XHUSTACMXHUSTACMXHUSTACMX”
  
Let A = “X”, Now I want to know the characters from L to R of the final string.

Input

Multiple test cases, in each test case, there are only one line containing two numbers L and R. 
1 <= L <= R <= 10^12 
R-L <= 100

Output

For each test case, you should output exactly one line which containing the   substring.

Sample Input

5 10

Sample Output

TACMXH


很容易发现,这串字符串是循环的,一眼题。。。。。XHUSTACMXHUSTACMXHUSTACMX



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cmath>
using namespace std;
char s[]="0XHUSTACM";
typedef long long ll;
int main()
{
	ll l,r,i,t;
	while(cin>>l>>r) {
		for(i=l;i<=r;i++) {
			t=i%8;
			if(t==0) t=8;
			cout<<s[t];
		}
		cout<<endl;
	}
	return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值