HUST 1606 判断一个数是否是3个数的立方和 (暴力)


Description

Give you a positive integer x, determine whether it is the sum of three positive cubic numbers.

Input

There’re several test cases. For each case: 
Only one line containing an integer x (  1≤x≤10^6)

Output

For each test case, print “Yes” if it is or “No” if it isn’t. 
(See sample for more details)

Sample Input

1
3
10

Sample Output

No
Yes
Yes


a*a*a+b*b*b+c*c*c = Y


预处理一下就好了


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<cmath>
using namespace std;
const int N = 9000000 + 100;
int f[N];
int main()
{
	int i,j,a,b,c,n;
	for(a=1;a<=100;a++) {
		for(b=1;b<=100;b++) {
			for(c=1;c<=100;c++)
			f[a*a*a+b*b*b+c*c*c]=1;
		}
	}
	while(scanf("%d",&n)!=EOF) {
		if(f[n]) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值