POJ 3278 爬格子 (bfs求最短路径)

18 篇文章 0 订阅
2 篇文章 0 订阅


题目大意,就是给出a和b点的横坐标,求到a,b的最小行动次数,其中每次行动只能是下面两种情况之一
  • 向左或向右移动一步,即横坐标加1或者减1
  • 横坐标变成原来的两倍
对于题目给出的数据5 17 , 可以这样进行行动 5 -> 10 -> 9 -> 18 -> 17 所以只需要四步就可以到达b

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source


额.... 花了2个小时,用dfs做,,,,, 看来自己还是太水了。。。

这里总结一下,dfs是求可行解(能不能到达目的地),是深度优先搜索。。。

bfs是用来搜索最短路径的,,,广度优先搜索。。。


dfs///bfs   堪称暴力美学,哈哈。。



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
struct node 
{
	int x;
	int cost;
};
queue<node>qq;
const int N = 1e5 + 10 ;
const int inf = 0x3f3f3f3f;
int a[N];
int main()
{
	int n,k,i,j;
	node t,tt;
	while(scanf("%d%d",&n,&k)!=EOF) {
		if(n>=k) {
			printf("%d\n",n-k);
			continue;
		}
		for(i=1;i<=k+1;i++) a[i]=inf;           // 记录起点是到i点的最短时间 
		while(!qq.empty()) qq.pop();
	    a[n]=0;
		t.x=n;
		t.cost=0;
		qq.push(t);
		while(!qq.empty()) {           //bfs
			tt=qq.front();
			qq.pop();
			if(tt.x==k) break;        //因为是广搜,搜索到的第一个一定是 Min_ans... 
			t.x=tt.x+1;
			t.cost=tt.cost+1;
			if(t.x<=k+1&&a[t.x]>t.cost) {   // 边界考虑,不能跑出k+1...能够证明跑出后的不是最小值 
				a[t.x]=t.cost;
				qq.push(t);
			}
			t.x=tt.x-1;
			t.cost=tt.cost+1;
			if(t.x>=0&&a[t.x]>t.cost) {
				a[t.x]=t.cost;
				qq.push(t);
			}
			t.x=tt.x<<1;
			t.cost=tt.cost+1;
			if(t.x<=k+1&&a[t.x]>t.cost) {
				a[t.x]=t.cost;
				qq.push(t);
			}
		}
		printf("%d\n",a[k]);
	}
	return 0;
}



把特殊情况,end>=start 先排除掉.....2A








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值