PAT 1104 Sum of Number Segments (暴力DFS)


Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:
4
0.1 0.2 0.3 0.4 
Sample Output:
5.00


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int a[22],N,K,P,b[1111],vis[1111],flag;

void dfs(int dis,int sum,int cnt)
{
	int i;
	if(sum>N || cnt>K) return;
	if(sum==N && cnt==K) {
		for(i=1;i<=20;i++) b[i]=vis[i];
		flag=1;
		return;
	}
	for(i=dis;i<=20;i++) {
		if(sum+a[i]>N) break;
		vis[i]++;
		dfs(i,sum+a[i],cnt+1);
		vis[i]--;
	}
}

int main()
{
	int i,j,f;
	scanf("%d%d%d",&N,&K,&P);
	for(i=1;i<=20;i++) {
		a[i]=i;
		for(j=1;j<P;j++)
		a[i]*=i;
	}
	flag=0;
	dfs(1,0,0);
	if(!flag) printf("Impossible\n");
	else {
		f=0;
		printf("%d =",N);
		for(i=20;i;i--) {
			while(b[i]--) {
				if(f) printf(" +");
				f=1;
				printf(" %d^%d",i,P);
			} 
		}
		printf("\n");
	} 
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值