HDU - 3652 B-number (数位DP)

8 篇文章 0 订阅


A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
Output
Print each answer in a single line.
Sample Input
13
100
200
1000
Sample Output
1
1
2
2



题意:找出1~n范围内含有13并且能被13整除的数字的个数

思路:使用记忆化深搜来记录状态,配合数位DP来解决


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int b[22];
int dp[22][22][2][15];
int dfs(int pos,int pre,int status,int r,int limit)
{
    if(pos<0) return (r==0 && status);
    if(!limit && dp[pos][pre][status][r]!=-1) return dp[pos][pre][status][r];
    int end = limit?b[pos]:9;
    int ret = 0;
    for(int i=0;i<=end;i++) {
        ret+=dfs(pos-1,i,status||(pre==1&&i==3),(r*10+i)%13,limit&&(i==end));
    }
    if(!limit) dp[pos][pre][status][r] = ret;
    return ret;
}
int work(int num)
{
    int cnt=0;
    memset(b,0,sizeof(b));
    while(num) {
        b[cnt++]=num%10;
        num/=10;
    }
    return dfs(cnt-1,9,0,0,1);
}
int main()
{
    int T,n;
    memset(dp,-1,sizeof(dp));
    while(scanf("%d",&n)!=EOF) {
        printf("%d\n",work(n));
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值