1025. 反转链表 (25)

给定一个常数K以及一个单链表L,请编写程序将L中每K个结点反转。例如:给定L为1→2→3→4→5→6,K为3,则输出应该为3→2→1→6→5→4;如果K为4,则输出应该为4→3→2→1→5→6,即最后不到K个元素不反转。

输入格式:

每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址、结点总个数正整数N(<= 105)、以及正整数K(<=N),即要求反转的子链结点的个数。结点的地址是5位非负整数,NULL地址用-1表示。

接下来有N行,每行格式为:

Address Data Next

其中Address是结点地址,Data是该结点保存的整数数据,Next是下一结点的地址。

输出格式:

对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。

输入样例:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
输出样例:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
//这道题是在陈越、何钦铭老师的数据结构课中有详细的讲解
//这道题的要注意的是一定要当做一个链表处理,尽量不要使用vector储存所有结构然后排序,容易超时,另外使用cout也容易超时

#include <iostream>
#include <string>
#include <cstdlib>

using namespace std;

struct Node{
	string address;
	int data;
	Node *next;
	void operator()(string a, int d,  Node * n) {
		address = a;
		data = d;
		next = n;
	}
};

Node list[100000];

void reverserList(Node *head, int k, int n,int c){

	if (c == n){
		return;
	}
	int cnt = 1;
	Node *nu = head->next;
	Node *old = nu->next;
	Node * tmp = old->next;;
	while (cnt < k){
		tmp = old->next;
		old->next = nu;
		nu = old; old = tmp;
		cnt++;
	}
	head->next->next = old;
	head->next = nu;
	tmp = nu;
	for (int i = 0; i < k-1; ++i){
		tmp = tmp->next;
	}
	reverserList(tmp, k, n, c+1);
}

int main(){

	int h, n, k; cin >>h>> n >> k;
	string address ;
	int data, next;
	Node tmp,head;
	head("", -1, &list[h]);

	while (n--){
		cin >> address >> data >> next;
		if (next == -1){
			 tmp(address, data, NULL);
		}
		else{
			 tmp(address, data, &list[next]);
		}
		int hash = atoi(address.c_str());
		list[hash] = tmp;
	}

	Node *p = head.next;
	int cnt = 1;
	while (p->next  !=  NULL){
		cnt++;
		p = p->next;
	}
	cnt /= k;
	reverserList(&head, k, cnt, 0);

	p = head.next;
	while (true){
		if (p->next == NULL){
			printf("%s %d -1\n", p->address.c_str(), p->data);
			break; 
		}
		printf("%s %d %s\n", p->address.c_str(), p->data,p->next->address.c_str());
		p = p->next;
	}

	system("pause");
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值