1032. 挖掘机技术哪家强(20)

为了用事实说明挖掘机技术到底哪家强,PAT组织了一场挖掘机技能大赛。现请你根据比赛结果统计出技术最强的那个学校。

输入格式:

输入在第1行给出不超过105的正整数N,即参赛人数。随后N行,每行给出一位参赛者的信息和成绩,包括其所代表的学校的编号(从1开始连续编号)、及其比赛成绩(百分制),中间以空格分隔。

输出格式:

在一行中给出总得分最高的学校的编号、及其总分,中间以空格分隔。题目保证答案唯一,没有并列。

输入样例:
6
3 65
2 80
1 100
2 70
3 40
3 0
输出样例:
2 150
//用一个map储存所有数据,之后遍历得到得分最高的学校

#include <iostream>
#include <map>

using namespace std;

map<int, int > schools;

int main(int argc, const char * argv[]) {

	int n; cin >> n;
	int school, score;

	while (n--){
		cin >> school >> score;
		if (schools.find(school) != schools.end()){
			schools[school] += score;
		}
		else{
			schools.insert(pair<int, int>(school, score));
		}
	}

	int maxSchool = 0, maxScore = -1;
	map<int, int >::iterator  itor = schools.begin();
	for (; itor != schools.end(); ++itor){
		if (itor->second>maxScore){
			maxScore = itor->second;
			maxSchool = itor->first;
		}
	}

	cout << maxSchool << " " << maxScore;

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值