Actcoder C-755

Problem Statement

You are given an integer N. Among the integers between 1 and N (inclusive), how many Shichi-Go-San numbers (literally "Seven-Five-Three numbers") are there?

Here, a Shichi-Go-San number is a positive integer that satisfies the following condition:

  • When the number is written in base ten, each of the digits 75 and 3 appears at least once, and the other digits never appear.

Constraints

  • 1≤N<109

N is an integer.


Input

Input is given from Standard Input in the following format:

N

Output

Print the number of the Shichi-Go-San numbers between 1 and N (inclusive).


Sample Input 1

575

Sample Output 1

4

There are four Shichi-Go-San numbers not greater than 575: 357,375,537 and 573.


Sample Input 2

3600

Sample Output 2

13

There are 13 Shichi-Go-San numbers not greater than 3600: the above four numbers, 735,753,3357,3375,3537,3557,3573,3575 and 3577.


Sample Input 3

999999999

Sample Output 3

26484

题目大意:

给您一个整数N。在1到N(含)之间的整数中,有多少个只包含 数字3,5,7且都至少出现一次

题解:

从零开始,等于每次加在尾数加三或者五,七之和(用三个bool类型表示3,5,7是否存在)

#include<iostream>
using namespace std;
long long n;
int dfs(long long x,bool A,bool B,bool C){
	if(x>n) return 0;
	long long ret=0;
	if(A&&B&&C) ret++;
	ret+=dfs(x*10+7,true,B,C);
	ret+=dfs(x*10+5,A,true,C);
	ret+=dfs(x*10+3,A,B,true) ;
	return ret;
}
int main()
{
	cin >> n;
	cout << dfs(0,false,false,false)<<endl ;
	return 0;	
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值