hdu 1312 Red and Black

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29940    Accepted Submission(s): 18118


 

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

 

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

 

 

Sample Input

 
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

 

Sample Output

 

45

59

6

13

//#include<bits/stdc++.h> 
#include<iostream> 
#include<algorithm>
#include<queue> 
using namespace std;
char room[23][23];
int dir[4][2] ={{-1,0},{0,-1},{1,0},{0,1}} ;
int wx,hy,num;
#define CHECK(x,y) (x<wx&&x>=0 && y>=0&&y<hy)
struct node {int x,y;};
void BFS(int dx,int dy) {
	num=1;
	queue<node>q;
	node start,next;
	start.x=dx;
	start.y=dy;
	q.push(start) ;
	while(!q.empty()) {
		start= q.front() ;
		q.pop() ;
		//cout <<"out" <<start.x<<" "<<start.y<<endl;
		for(int i=0;i<4;i++) {
			next.x=start.x+dir[i][0] ;
			next.y=start.y+dir[i][1] ;
			if(CHECK(next.x,next.y)&&room[next.x][next.y]=='.'){
				room[next.x][next.y ] ='#' ;
				num++;
				q.push(next);
			}
		}
	}
	
}
int main()
{
	int x,y,dx,dy;
	while(cin >> wx>>hy) {
		if(wx==0&&hy==0) break;
		for(y=0;y<hy;y++) {
			for(x=0;x<wx;x++) {
				cin >>room[x][y] ;
				if(room[x][y]=='@' ) {
					dx=x;dy=y;
				}
			}
		}
		//cout <<dx<<dy<<endl;
		BFS(dx,dy) ;
		cout <<num<<endl;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值