The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
Sample Output
105 10296
题解:构建一个函数求两个数的最大公约数即可
代码c:
#include <stdio.h>
#include <stdlib.h>
int lcm(int a,int b)
{
int t,x,y,lcm;
x=a;
y=b;
if(a<b){
t=a;
a=b;
b=t;
}
while(b!=0){
t=a;
a=b;
b=t%b;
}
lcm=x/a*y;
return lcm;
}//构建函数求两个数的最小公倍数,即lcm
int main()
{
int t,i,m,a,b;
scanf("%d",&t);
while(t--){
scanf("%d",&m);
scanf("%d",&a);
for(i=1;i<m;i++){
scanf("%d",&b);
a=lcm(a,b);
}
printf("%d\n",a);
}
return 0;
}