Problem Description
N个气球排成一排,从左到右依次编号为1,2,3…N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
Sample Input
3
1 1
2 2
3 3
3
1 1
1 2
1 3
0
Sample Output
1 1 1
3 2 1
思路:看看笔记哦
可能会有一点点不太理解,但是这个是板子要记得这么写哦,在单点查询那里可能会有点点奇怪,另外,java数组再次初始化,在数组中重新写一句 bit = new int[100005]就OK啦,,,不然会累加的
import java.util.Scanner;
class Main{
public static int N;
public static int bit[] = new int[100005];
public static void main(String[] args) {
Scanner sc= new Scanner(System.in);
while (true){
N = sc.nextInt();
bit = new int[100005];
if(N==0) break;
for(int i=0;i<N;i++){
int a = sc.nextInt();
int b = sc.nextInt();
add(a,1);
add(b+1,-1);
}
for(int i = 1;i<=N;i++){
System.out.print(sum(i)+" ");
}
}
}
static int sum(int i){
int s = 0;
while (i>0){
s+= bit[i];
i-= i&(-i);
}
return s;
}
static void add(int i,int x){
while (i<=N){
bit[i]+= x;
i+= i&(-i);
}
}
}