大数相加

题目:

杭电上的

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 392965    Accepted Submission(s): 76103


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

题解,就是简单的大数相加,不过杭电的数据有点问题,刚开始造的代码有个细节没处理竟然也过了,但是南阳理工上提交不上,后来改好了哈哈

贴上我搞笑代码:

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
int main()
{
    int n,m=1;
    cin>>n;
    int T=n;
    while(T--)
    {
    string str1,str2;
   int a[10000],b[10000],c[10000],i,j;
   memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
     memset(c,0,sizeof(c));
   cin>>str1>>str2;
   int temp=0;
   int len1=strlen(&str1[0])-1;
   for(i=len1;i>=0;--i)
   a[temp++]=str1[i]-'0';

   temp=0;
   int len2=strlen(&str2[0])-1;
   for(j=len2;j>=0;--j)
    b[temp++]=str2[j]-'0';

   int x=len1,y=len2,t=0,f=0;
   for(i=0,j=0;i<=x||j<=y;i++,j++)
   {
       c[f++]=(a[i]+b[j]+t)%10;
       t=(a[i]+b[j]+t)/10;
       if(t>0&&(i>=x&&j>=y))
       {
           x++;
           y++;
       }
   }
   cout<<"Case "<<m<<":"<<endl;
   cout<<str1<<" + "<<str2<<" = ";
   for(i=f-1;i>=0;i--)
    cout<<c[i];
    cout<<endl;
    if(m!=n)//空格处理
    cout<<endl;
   m++;
    }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值