2264 Card Game (First Edition)

                                                                        Problem 2264 Card Game (First Edition)

                                                                   Accept: 138    Submit: 392
                                             Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game with some cards. There are N*2 cards in this game for the players to use, this is the card deck. The game goes for N rounds and in each round, Fat Brother would draw one card from the remaining card deck randomly and then Maze would draw one card from the remaining card deck randomly. Then they compare for the integers which is written on these two cards. The player with the higher number wins this round and score 1 victory point. And then these two cards are removed from the game such that they would not appear in the later rounds. As we all know, Fat Brother is very clever, so he would like to know the expect number of the victory points he could get if he knows all the integers written in these cards.

Note that the integers written on these N*2 cards are pair wise distinct. At the beginning of this game, each player has 0 victory point.

Input

The first line of the data is an integer T (1 <= T <= 100), which is the number of the text cases.

Then T cases follow, each case contains an integer N (1 <= N<=10000) which described before. Then follow one line with N*2 integers, which indicate the integers in these cards.

All the integers are positive and no morethan 10000000.

Output

For each case, output the case number first, and then output the expect number of the victory points Fat Brother could get in this game. The answer should be rounded to 2 digits after the decimal point.

Sample Input

211 221 2 3 4

Sample Output

Case 1: 0.50Case 2: 1.00

Source

[题解】:

比较x与x+2侄儿两个数,大的point就加;基本没有什么吧,可能是我的英语,语文水平没这么好吧



【代码】:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<vector>
#include<map>
#define MAX 21000
using namespace std;
int a1[MAX];
bool cmp(int a,int b){
    return a>b;
}
int main()
{
    int re;
    scanf("%d",&re);
    for(int i=1;i<=re;i++)
    {
        int n;
        double point=0.0;
        scanf("%d",&n);
        for(int t=0;t<n*2;t++){
            scanf("%d",&a1[t]);
        }
        sort(a1,a1+n+n,cmp);
        int cnt=0;
        int x=n;
        for(int k=n;k<n*2;k++){
            if(a1[cnt++]>a1[k]){
                point++;
                cnt++;
            }
        }
        printf("Case %d: %.2f\n",i,point/2);
    }
    return 0;
}


其实这道题还可以很恶心的解法,有数学素养的人,就一眼看出来了,然而,我并没有看出来

【代码】:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<vector>
#include<map>
#define MAX 21000
using namespace std;
int a1[MAX];
bool cmp(int a,int b){
    return a>b;
}
int main()
{
    int re,cn=1;
    scanf("%d",&re);
    while(re--)
    {
        int num;
        double n;
        scanf("%lf",&n);
        for(int t=0;t<n*2;t++)
            scanf("%d",&num);
        printf("Case %d: %.2f\n",cn++,n/2.0);
    }
    return 0;
}




第七届福建省大学生程序设计竞赛-重现赛(感谢承办方闽江学院)
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值