友谊赛 最小生成树

C - 我必须立即行动!
Time Limit:2000MS      Memory Limit: 32768KB      64bit IO Format: %lld & %llu

Description

Tanvir returned home from the contest and got angry after seeing his room dusty. Who likes to see a dusty room after a brain storming programming contest? After checking a bit he found that there is no brush in him room. So, he called Atiq to get a brush. But as usual Atiq refused to come. So, Tanvir decided to go to Atiq's house.

The city they live in is divided by some junctions. The junctions are connected by two way roads. They live in different junctions. And they can go to one junction to other by using the roads only.

Now you are given the map of the city and the distances of the roads. You have to find the minimum distance Tanvir has to travel to reach Atiq's house.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a blank line. The next line contains two integers N (2 ≤ N ≤ 100) and M (0 ≤ M ≤ 1000), means that there are N junctions and Mtwo way roads. Each of the next M lines will contain three integers u v w (1 ≤ u, v ≤ N, w ≤ 1000), it means that there is a road between junction u and vand the distance is w. You can assume that Tanvir lives in the 1st junction and Atiq lives in the Nth junction. There can be multiple roads between same pair of junctions.

Output

For each case print the case number and the minimum distance Tanvir has to travel to reach Atiq's house. If it's impossible, then print 'Impossible'.

Sample Input

2

 

3 2

1 2 50

2 3 10

 

3 1

1 2 40

Sample Output

Case 1: 60

Case 2: Impossible

//模板题,代码参考如下;

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int d[10010];
bool used[10010];
int cost[1010][1010];
int n,m;
void dijkstra(int s)
{
  int i,j,v;
  for(i=1;i<=n;i++)
    {
      d[i]=INF;
      used[i]=false;
    }
   d[s]=0;
 while(true)
 {
      v=-1;
  for(int u=1;u<=n;u++)
    if(!used[u]&&(v==-1||d[u]<d[v]))
      v=u;
   if(v==-1) break;
   used[v]=true;
   for(int u=1;u<=n;u++)
    d[u]=min(d[u],d[v]+cost[v][u]);  
 } 
}
int main()
{ int t;
  int k=1;
  scanf("%d",&t);
  while(t--)
   {
      //printf("\n");
   scanf("%d%d",&n,&m);
   for(int i=1;i<=n;i++)
     for(int j=1;j<=n;j++)
        cost[i][j]=INF;
  int a,b,c;
  while(m--)
  {  // int a,b,c;
    scanf("%d%d%d",&a,&b,&c);
    if(c<cost[a][b])
      cost[a][b]=cost[b][a]=c;
  }      
  dijkstra(1);
  if(d[n]==INF)
  printf("Case %d: Impossible\n",k);  
      else
     printf("Case %d: %d\n",k,d[n]);
       k++;
   }
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值