HDU - 1563 Find your present!

In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
InputThe input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.OutputFor each case, output an integer in a line, which is the card number of your present.Sample Input
5
1 1 3 2 2
3
1 2 1
0
Sample Output
3
2

用^,a^a=0,0^a=a;

我觉得这个想法很巧妙。我的思路还停留在for循环上

#include<stdio.h>
int main(void){
    int n,ans,val;
    while(scanf("%d",&n)!=EOF){
        if(n==0)
            break;
        ans=0;
        
        while(n--){
            scanf("%d",&val);
            ans^=val;
        }
        printf("%d\n",ans);
    }
    return 0;
}

这个还不太对

#include<stdio.h>
#include<string.h>
int main(void){
    int n,a[201],b[201];
    int i,j;

    while(scanf("%d",&n)!=EOF){
        memset(b,1,sizeof(b));
        if(n==0)
            break;
        for(i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        for(i=0;i<n-1;i++){
            for(j=1;j<n;j++){
                if(a[i]==a[j]){
                    b[i]=0;
                    b[j]=0;
                    }
            }
        }
        for(i=0;i<n;i++){
            if(b[i]==1)
                printf("%d\n",a[i]);
        }
    }

    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值