poj 1456 并查集

Supermarket
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7838 Accepted: 3334

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185
题意是:

有N件商品,分别给出商品的价值和销售的最后期限,只要在最后日期之前销售处,就能得到相应的利润,并且销售该商品需要1天时间。

问销售的最大利润。

这是一道相当的有意思的并查集题目,我最开始看到这个感觉是个纯贪心的题目,后来看了解题报告发现要用贪心和优先队列,当时就跪了,弱菜不会贪心,也不会优先队列,但是这个题既然是在并查集的分类,肯定是可以写的,最后发现其实,并查集的目的就是用来查询的,首先将截止日期排序,然后运用并查集从根节点开始查找,如果根节点被占用,就往前查找 ,直到找到为止。
下面是代码:
 
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define N 10010
using namespace std;
int pre[N];
struct node{
    int porfit;
    int deadline;
}p[N];

bool operator < (const node &a,const node &b){
     return a.porfit>b.porfit;
}

int find(int x){
    int r=x;
    while(pre[r]!=r){
         r=pre[r];
    }
    int i=x;
    int j;
    while(i!=r){
         j=pre[i];
         pre[i]=r;
         i=j;
    }
    return r;
}

void init(){
     for(int i=1;i<N;++i)
        pre[i]=i;
}
int main(){
    int maxporfit;
    int root;
    int n;
    while(scanf("%d",&n)!=EOF){
         maxporfit=0;
          init();
       for(int i=0;i<n;++i)
          scanf("%d%d",&p[i].porfit,&p[i].deadline);
       sort(p,p+n);
       for(int i=0;i<n;++i){
            root=find(p[i].deadline);
            if(root>0){
                 pre[root]=root-1;
                 maxporfit+=p[i].porfit;
            }
       }
       cout<<maxporfit<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值