UVA-230 Borrowers 模拟

Like Mr. Lamb, librarians have their problems with borrowers too. People don’t put books back where
they should. Instead, returned books are kept at the main desk until a librarian is free to replace them
in the right places on the shelves. Even for librarians, putting the right book in the right place can
be very time-consuming. But since many libraries are now computerized, you can write a program to
help.
When a borrower takes out or returns a book, the computer keeps a record of the title. Periodically,
the librarians will ask your program for a list of books that have been returned so the books can be
returned to their correct places on the shelves. Before they are returned to the shelves, the returned
books are sorted by author and then title using the ASCII collating sequence. Your program should
output the list of returned books in the same order as they should appear on the shelves. For each
book, your program should tell the librarian which book (including those previously shelved) is already
on the shelf before which the returned book should go.
Input
First, the stock of the library will be listed, one book per line, in no particular order. Initially, they are
all on the shelves. No two books have the same title. The format of each line will be:
title" by author
The end of the stock listing will be marked by a line containing only the word:
END
Following the stock list will be a series of records of books borrowed and returned, and requests
from librarians for assistance in restocking the shelves. Each record will appear on a single line, in one
of the following formats:
BORROW title
RETURN title
SHELVE
The list will be terminated by a line containing only the word:
END
Output
Each time the SHELVE command appears, your program should output a series of instructions for the
librarian, one per line, in the format:
Put title1 after title2
or, for the special case of the book being the first in the collection:
Put title first
After the set of instructions for each SHELVE, output a line containing only the word:
END
Assumptions & Limitations:
1. A title is at most 80 characters long.
2. An author is at most 80 characters long.
3. A title will not contain the double quote (") character.
Sample Input
"The Canterbury Tales" by Chaucer, G.
"Algorithms" by Sedgewick, R.
"The C Programming Language" by Kernighan, B. and Ritchie, D.
END
BORROW "Algorithms"
BORROW "The C Programming Language"
RETURN "Algorithms"
RETURN "The C Programming Language"
SHELVE
END
Sample Output
Put "The C Programming Language" after "The Canterbury Tales"
Put "Algorithms" after "The C Programming Language"
END

#include<bits/stdc++.h>
using namespace std;
const int maxlen = 80+5,maxn = 1000+10;

struct Book{
    char name[maxlen];
    char author[maxlen];
    bool operator < (const Book & b){
        int r1=strcmp(author,b.author);
        int r2=strcmp(name,b.name);
        if(r1!=0){
            if(r1<0) return true;
            return false;
        }
        else{
            if(r2<0) return true;
            return false;
        }
    }
}books[maxn];

int n=0;
map<string,int>state;

int find_pre(int cur){
    for(int i=cur-1;i>=0;i--){
        if(state[books[i].name]==1) return i;
    }
    return -1;
}

int main(){
  //  freopen("datain.txt","r",stdin);
    char buf[maxlen];
    int pos;
    state.clear();
    while(gets(buf)){
        if(strcmp(buf,"END")==0)break;
        pos=strchr(buf+1,'"')-buf;
        strncpy(books[n].name,buf,pos+1);
        books[n].name[pos+2]='\0';
        strcpy(books[n].author,buf+pos+5);
        state[books[n].name]=1;
        n++;
    }
    sort(books,books+n);
    while(~scanf("%s",buf)){
        if(strcmp(buf,"END")==0)break;
        if(strcmp(buf,"BORROW")==0){
            gets(buf);
            state[buf+1]=0;
        }
        else if(strcmp(buf,"RETURN")==0){
            gets(buf);
            state[buf+1]=2;
        }
        else if(strcmp(buf,"SHELVE")==0){
            for(int i=0;i<n;i++)
                if(state[books[i].name]==2){
                    pos=find_pre(i);
                    if(pos==-1) printf("Put %s first\n",books[i].name);
                    else printf("Put %s after %s\n",books[i].name,books[pos].name);
                    state[books[i].name]=1;
            }
            puts("END");
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值