本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中所有存储了某给定值的结点删除。链表结点定义如下:
struct ListNode {
int data;
ListNode *next;
};
函数接口定义:
struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );
函数readlist从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1时表示输入结束,函数应返回指向单链表头结点的指针。
函数deletem将单链表L中所有存储了m的结点删除。返回指向结果链表头结点的指针。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *readlist();
struct ListNode *deletem( struct ListNode *L, int m );
void printlist( struct ListNode *L )
{
struct ListNode *p = L;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
int m;
struct ListNode *L = readlist();
scanf("%d", &m);
L = deletem(L, m);
printlist(L);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
10 11 10 12 10 -1
10
输出样例:
11 12
- 答案:
- 注意删除结点在头结点时的处理。
struct ListNode *readlist(){
int a;
scanf("%d",&a);
struct ListNode *p=NULL,*q,*h=NULL;
while(a!=-1){
q=(struct ListNode*)malloc(sizeof(struct ListNode));
q->data=a;
q->next=NULL;
if(h==NULL){
h=q;
p=q;
}
else{
p->next=q;
p=q;
}
scanf("%d",&a);
}
return h;
}
struct ListNode *deletem(struct ListNode *L,int m){
struct ListNode *p=L,*q=L;
while(q!=NULL){
if(q->data==m){
if(q==L){
L=L->next;
p=L;
free(q);
q=L;
}
else{
p->next=q->next;
free(q);
q=p->next;
}
}
else{
p=q;
q=q->next;
}
}
return L;
}