1104 Sum of Number Segments (20分)

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10​5​​. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

#include <iostream>
#include <vector>

using namespace std;

int main()
{
	//freopen("in.txt", "r", stdin);
	int n;
	cin >> n;
	double sum = 0.0, temp;
	for (int i = 1; i <= n; i++)
	{
		cin >> temp;
		sum += temp * i*(n - i + 1);
	}
	printf("%.2lf", sum);
	return 0;
}

改了测试数据后,测试点2不过,目前怀疑是因为测试数据里加入了重复数。猜测不对!

原因:

改了之后:

#include <iostream>
using namespace std;
int main() {
    int n;
    cin >> n;
    long long sum = 0;
    double temp;
    for (int i = 1; i <= n; i++) { 
        cin >> temp;
        sum += (long long)(temp * 1000) * i * (n - i + 1);
    }
    printf("%.2f", sum / 1000.0);
    return 0;
}

也可以这样:将double改为long double

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
int main()
{
  int N;
  scanf("%d", &N);
  long double sum = 0.0, tmp;
  for(int i=0; i<N; i++)
  {
    scanf("%llf", &tmp);
    sum += tmp * (N-i) * (i+1);
  }
  printf("%.2llf", sum);
  return 0;
}

试了下java做法:不全对:

import java.io.IOException;
import java.math.BigDecimal;
import java.nio.file.Paths;
import java.text.DecimalFormat;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) throws IOException {
        //long startTime = System.currentTimeMillis();
        Scanner in = new Scanner(System.in);
        //Scanner in = new Scanner(Paths.get("in"), "UTF-8");
        int n = in.nextInt();

        BigDecimal sum = BigDecimal.valueOf(0), temp=BigDecimal.valueOf(0);
        for (int i = 0; i < n; i++) {
            if (in.hasNext())
                temp = BigDecimal.valueOf(in.nextDouble());
            sum = sum.add(temp.multiply(BigDecimal.valueOf((n - i) * (i + 1))));
        }

        System.out.println(new DecimalFormat("#.00").format(sum));
        //long endTime = System.currentTimeMillis();
        //System.out.println((endTime - startTime) + "ms");
    }

}

结果:

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值