Consider a positive integer N written in standard notation with k+1 digits ai as ak⋯a1a0 with 0≤ai<10 for all i and ak>0. Then N is palindromic if and only if ai=ak−i for all i. Zero is written 0 and is also palindromic by definition.
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )
Given any positive integer, you are supposed to find its paired palindromic number.
Input Specification:
Each input file contains one test case which gives a positive integer no more than 1000 digits.
Output Specification:
For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:
A + B = C
where A
is the original number, B
is the reversed A
, and C
is their sum. A
starts being the input number, and this process ends until C
becomes a palindromic number -- in this case we print in the last line C is a palindromic number.
; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations.
instead.
Sample Input 1:
97152
Sample Output 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
Sample Input 2:
196
Sample Output 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.
吾思:
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
string rev(string s)
{
reverse(s.begin(), s.end());
return s;
}
bool isPalind(string s)
{
// int len = s.length();
// if (s=="0"||len==1)
// {
// return true;
// }
// for (int i = 0; i <= len/2; i++)
// {
// if (s[i]!=s[len-i-1])
// {
// return false;
// }
// }
// return true;
if (s==rev(s))
{
return true;
}
return false;
}
int main()
{
// freopen("in.txt", "r", stdin);
string s;
int cnt = 0;
cin >> s;
if (!isPalind(s))
{
while (!isPalind(s)&&cnt<10)
{
long long temp = stoll(s);
cout << s << " + ";
reverse(s.begin(), s.end());
temp += stoi(s);
cout << s << " = "<<temp<<endl;
s = to_string(temp);
cnt++;
}
}
if (isPalind(s))
{
cout << s << " is a palindromic number." << endl;
}
else
{
cout << "Not found in 10 iterations." << endl;
}
return 0;
}
结果:
应该是位数(1000位)太多,直接相加超范围。
正确:
#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
using namespace std;
string rev(string s)
{
reverse(s.begin(), s.end());
return s;
}
string add(string s1, string s2)
{
string s=s1;
int carry = 0;
for (int i = s1.size()-1; i >=0; i--)
{
s[i] = (s1[i] - '0' + s2[i] - '0' + carry) % 10+'0';
carry = (s1[i] - '0' + s2[i] - '0' + carry) / 10;
}
if (carry > 0)
{
s = to_string(carry) + s;
}
return s;
}
int main()
{
//freopen("in.txt", "r", stdin);
string s, sum;
cin >> s;
if (s.length() == 1 || s == rev(s))
{
cout << s << " is a palindromic number.";
return 0;
}
int cnt = 0;
while (s != rev(s) && cnt < 10)
{
sum = add(s, rev(s));
cout << s << " + " << rev(s) << " = " << sum << endl;
s = sum;
cnt++;
}
if (cnt!=10)
{
cout << s << " is a palindromic number.";
}
else
{
cout << "Not found in 10 iterations.";
}
return 0;
}