1127 ZigZagging on a Tree (30分) 中序后序建树 层次遍历

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

 吾:用cmp 省一个bfs  两个点不过:待完善  已解决

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

vector<int> in, post;
int level = 1;
const int inf = 99999;
struct node
{
	int index, level = inf, data;
};

bool cmp(node a, node b)
{
	if (a.level != b.level)
	{
		return a.level < b.level;
	}
	else if (a.level % 2 == 1)
	{
		return a.index > b.index;
	}
	else if(a.level%2==0)
	{
		return a.index < b.index;
	}
}

vector<node> v;
void dfs(int root, int inleft, int inright, int postleft, int postright, int level)
{
	if (inleft > inright)
	{
		return;
	}
	v[root].index = root;
	v[root].data = post[postright];
	v[root].level = level;
	int i = 0;
	while (in[i] != post[postright])
	{
		i++;
	}
	dfs(root * 2, inleft, i - 1, postleft, postleft + (i - inleft) - 1, level + 1);
	dfs(root * 2 + 1, i + 1, inright, postleft + (i - inleft), postright - 1, level + 1);
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n;
	cin >> n;
	in.resize(n + 1);
	post.resize(n + 1);
	/*原来的错误代码:
	v.resize(n * 2 + 2);*/

	v.resize(11100);//这个代码的问题就是这里的数组开小了  我看了好久,
	//因为想到了在index的方法中最后一个点的index可能大于n的,不是n个点
	//最大的index就是n,所以考虑极端情况,每个点都是父节点的右孩子:第二个点就是1*2+1,第三个就是(1*2+1)*2+1,30个点会很大,
	//所以把此数组开大,那个测试点1和3就过了
	for (int i = 1; i <= n; i++)
	{
		cin >> in[i];
	}
	for (int i = 1; i <= n; i++)
	{
		cin >> post[i];
	}
	dfs(1, 1, n, 1, n, 1);
	sort(v.begin(), v.end(), cmp);
	cout << v[0].data;
	for (int i = 1; i < n; i++)
	{		
			cout << " " << v[i].data;
	}
	cout << endl;
	return 0;
}

吾(2):自己想的这两种方法也只是建树和输出方式不同。核心思路一样。

#include <iostream>
#include <vector>

using namespace std;

int n;
vector<int> in, post;

int cnt = 0;
vector<int> level[36];

void gettree(int l, int inleft, int inright, int postleft, int postright)
{
	if (postleft > postright)
	{
		return;
	}

	level[l].push_back(post[postright]);

	int i = 1;
	while (in[i] != post[postright])
	{
		i++;
	}
	//是这里的范围写的不太对  原代码:
	/*gettree(l + 1, inleft, i - 1, postleft, postleft + i - inleft - 1);
	gettree(l + 1, inleft + i, inright, postleft + i - 1, postright - 1);*/

	//这是对的:
	gettree(l + 1, inleft, i - 1, postleft, postleft + i - inleft - 1);
	gettree(l + 1, i+1, inright, postleft + i - inleft, postright - 1);
}

int main()
{
	//freopen("in.txt", "r", stdin);
	cin >> n;
	in.resize(n + 1), post.resize(n + 1);
	for (int i = 1; i <= n; i++)
	{
		cin >> in[i];
	}
	for (int i = 1; i <= n; i++)
	{
		cin >> post[i];
	}

	gettree(1, 1, n, 1, n);

	for (int i = 0; i < 36; i++)
	{
		if (i % 2 == 0)
		{
			for (int j = 0; j < level[i].size(); j++)
			{
				cout << " " << level[i][j];
			}
		}
		else
		{
			for (int j = level[i].size() - 1; j >= 0; j--)
			{
				if (i == 1)
				{
					cout << level[i][j];
				}
				else
				{
					cout << " " << level[i][j];
				}
			}
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值