1143 Lowest Common Ancestor (30分) 注意平衡二叉树的特性(大小关系) 要巧妙利用这一点

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
#include <iostream>
#include <vector>
#include <map>

using namespace std;

int main()
{
	//freopen("in.txt", "r", stdin);
	int m, n,u,v,a;
	cin >> m >> n;
	vector<int> pre(n);
	map<int, bool> map;
	for (int i = 0; i < n; i++)
	{
		cin >> pre[i];
		map[pre[i]] = true;
	}
	for (int i = 0; i < m; i++)
	{
		cin >> u >> v;
		for (int j = 0; j < n; j++)
		{
			a = pre[j];
			if ((a>=u&&a<=v)||(a>=v&&a<=u))
			{
				break;
			}
		}
		if (map[u]==false&&map[v]==false)
		{
			printf("ERROR: %d and %d are not found.\n", u, v);
		}
		else if (map[u]==false||map[v]==false)
		{
			printf("ERROR: %d is not found.\n", map[u] == false ? u : v);
		}
		else if (a==u||a==v)
		{
			printf("%d is an ancestor of %d.\n", a, a == u ? v : u);
		}
		else
		{
			printf("LCA of %d and %d is %d.\n", u, v, a);
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值