1154 Vertex Coloring (25分) 常规题 逻辑麻烦些 SET 算简单题

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

作者

陈越

单位

浙江大学

代码长度限制

16 KB

时间限制

900 ms

内存限制

64 MB

大意:n、m分别为图的点和边数目,每条边的两个端点不能用同样的颜色,给出k行颜色集合,一个集合里是每个点所用的颜色,问是否满足边两端颜色不同,如果满足了,那么n个点一共用了p种颜色,即为p-coloring。

一刷:吾:这题时间限制很宽,算是放我一马了.

#include <iostream>
#include <vector>
#include <set>

using namespace std;

const int maxn = 10006;

vector<int> v[10006];


int main()
{
	//freopen("in.txt", "r", stdin);
	int n, m, k;
	cin >> n >> m;
	for (int i = 0; i < m; i++)
	{
		int a, b;
		cin >> a >> b;
		v[a].push_back(b);
		v[b].push_back(a);
	}
	cin >> k;

	for (int i = 0; i < k; i++)
	{
		vector<int> col(n);
		set<int> s;
		for (int j = 0; j < n; j++)
		{
			cin >> col[j];//这个地方又写成i了,犯了几次这样的错误不细心啊  昊昊小伙子。
			s.insert(col[j]);
		}
		int flag = 1;
		for (int j = 0; j < n; j++)
		{
			if (flag == 0)
			{
				break;
			}
			for (int t = 0; t < v[j].size(); t++)
			{
				if (col[v[j][t]] == col[j])
				{
					cout << "No" << endl;
					flag = 0;
					break;
				}
			}
		}
		if (flag == 1)
		{
			printf("%d-coloring\n", s.size());
		}
	}
	return 0;
}

 柳: 确实耗时少很多。思路一样但是耗时少很多

 

#include <iostream>
#include <vector>
#include <set>

using namespace std;



struct node
{
	int t1, t2;
};

int main()
{
	//freopen("in.txt", "r", stdin);
	int n, m, k;
	cin >> n >> m;
	vector<node> v(m);
	for (int i = 0; i < m; i++)
	{
		scanf("%d %d", &v[i].t1, &v[i].t2);
	}
	cin >> k;
	while (k--)
	{
		int a[10008] = { 0 };
		bool flag = true;
		set<int> se;
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &a[i]);
			se.insert(a[i]);

		}
		for (int i = 0; i < m; i++)
		{
			if (a[v[i].t1]==a[v[i].t2])
			{
				flag = false;
				break;
			}
		}
		if (flag)
		{
			printf("%d-coloring\n", se.size());
		}
		else
		{
			printf("No\n");
		}
	}
	return 0;
}

 二刷:吾:

 

#include <iostream>
#include <set>	
#include <vector>

using namespace std;

const int maxn = 10006;

int main()
{
	//freopen("in.txt", "r", stdin);
	int n, m;
	cin >> n >> m;
	vector<int> v[maxn];
	for (int i = 0; i < m; i++)
	{
		int a,b;
		cin >> a >> b;
		v[a].push_back(b);
		v[b].push_back(a);
	}
	int k;
	cin >> k;
	for (int t = 0; t < k; t++)
	{
		set<int> s;
		vector<int> cv(n);
		bool flag = true;
		for (int i = 0; i < n; i++)
		{
			
			cin >> cv[i];
			s.insert(cv[i]);
		}
		for (int i = 0; i < maxn; i++)
		{
			if (v[i].size()!=0)
			{
				for (int j = 0; j < v[i].size(); j++)
				{
					if (cv[i] == cv[v[i][j]])
					{
						cout << "No" << endl;
						flag = false;
						break;
					}
				}	
				if (!flag)
				{
					break;
				}
			}
		}
		if (!flag)
		{
			continue;
		}
		printf("%d-coloring\n", s.size());
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值