1064 Complete Binary Search Tree (30分) 完全二叉搜索树 层序遍历 递归 经典好题

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

 柳:绝了!!!

#include <iostream> 
#include <cmath>
#include <vector>
#include <algorithm>

using namespace std;

vector<int> in, level;
void levelorder(int start, int end, int index)
{
	if (start>end)
	{
		return;
	}
	int n = end - start + 1;//n个点,尾-首+1
	int l = log(n + 1) / log(2);//除最后一层外的层数,l=以2为底n+1的对数,n层的总点数是2的l次方-1嘛,这里倒回去算层数要加1.
	int leave = n - (pow(2, l) - 1);//总数减去前l层(前l层是完整的),剩下即最后一层的数目
	int root = start + pow(2, l - 1) - 1 + min(int(pow(2, l - 1)), leave);//pow(2,l-1)-1是那l层中 成为根节点的左子树的点,l层减去根节点那层,so 是2的l-1次方,然后-1即可。
	//pow(2,l-1)为第l+1层成为根节点左子树的最多情况下的数目,leave为最后一层的叶子节点数目,叶子节点不够最后一层的一半(取叶子结点)和叶子结点大于最后一层的一半(取最后一次的一半)两种情况
	level[index] = in[root];
	levelorder(start, root - 1, index * 2 + 1);
	levelorder(root + 1, end, index * 2 + 2);
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n;
	cin >> n;
	level.resize(n);
	for (int i = 0; i < n; i++)
	{
		int t;
		cin >> t;
		in.push_back(t);
	}
	sort(in.begin(), in.end());
	levelorder(0, n - 1, 0);
	cout << level[0];
	for (int i = 1; i < n; i++)
	{
		cout << " " << level[i];
	}
	cout << endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值