1066 Root of AVL Tree (25分) 平衡二叉树 经典递归

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

 柳:

#include <iostream>
#include <vector>
#include <cmath>
#include <algorithm>

using namespace std;

struct node
{
	int value;
	struct node *left, *right;
};

node* rotateLeft(node* root)
{
	node *t = root->right;
	root->right = t->left;
	t->left = root;
	return t;
}

node * rotateRight(node *root)
{
	node *t = root->left;
	root->left = t->right;
	t->right = root;
	return t;
}

node *rightToleft(node *root)
{
	root->right = rotateRight(root->right);
	return rotateLeft(root);
	
}

node *leftToright(node *root)
{
	root->left = rotateLeft(root->left);
	return rotateRight(root);
}

int getHeight(node *root)
{
	if (root==NULL)
	{
		return 0;
	}
	return max(getHeight(root->left), getHeight(root->right)) + 1;
}

node* insert(node *root,int value)
{
	if (root==NULL)
	{
		root = new node();
		root->value = value;
		root->left = root->right = NULL;
	}
	else if (value<root->value)
	{
		root->left = insert(root->left,value);
		if (getHeight(root->left)-getHeight(root->right)==2)
		{
			root = (value < root->left->value) ? rotateRight(root) : leftToright(root);
		}
	}
	else
	{
		root->right = insert(root->right, value);
		if (getHeight(root->right)-getHeight(root->left)==2)
		{
			root = (value > root->right->value) ? rotateLeft(root) : rightToleft(root);
		}
	}
	return root;
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n;
	cin >> n;
	node *root = NULL;
	for (int i = 0; i < n; i++)
	{
		int t;
		cin >> t;
		root=insert(root,t);
	}
	cout << root->value << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值