1072 Gas Station (30分) dijkstar算法 复杂化:多次Dijkstra+带些附加的计算要求 经典

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10​3​​), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10​4​​), the number of roads connecting the houses and the gas stations; and D​S​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

 大意:找一个加油站在距离各民居不超过服务距离的条件下尽可能远离民居,多个选择的话,最小平均距离优先,还不行的话,index小的优先。

 一刷:柳:

#include <iostream>
#include <vector>
#include <string>	

using namespace std;

const int inf = 999999;
int n, m,  k,ds;
int e[1060][1060], dis[1060];
bool visit[1060];

int main()
{
	//freopen("in.txt", "r", stdin);
	fill(e[0], e[0] + 1060*1060, inf);
	fill(dis, dis + 1060, inf);
	cin >> n >> m>>k>>ds;
	for (int i = 0; i < k; i++)
	{
		string start, end;
		int tempdis,a,b;
		cin >> start >> end>>tempdis;
		if (start[0]=='G')
		{
			a = n+stoi(start.substr(1));
		}
		else
		{
			a = stoi(start);
		}
		if (end[0]=='G')
		{
			b = n + stoi(end.substr(1));
		}
		else
		{
			b = stoi(end);
		}
		e[a][b] = e[b][a] = tempdis;
	}
	int ansid = -1;
	double ansdis = -1, ansaver = inf;
	for (int index = n+1; index <= n+m; index++)//多源点,重复用dijkstra算法
	{
		double mindis = inf, aver = 0;
		fill(dis, dis + 1060, inf);
		fill(visit, visit + 1060, false);
		dis[index] = 0;
		for (int i = 0; i < n+m; i++)
		{
			int u = -1,minn=inf;
			for (int j = 1; j <= n+m; j++)
			{
				if (visit[j]==false&&dis[j]<minn)
				{
					minn = dis[j];
					u = j;
				
				}
			}
			if (u==-1)
			{
				break;
			}
			visit[u] = true;
			for (int v = 1; v <= n+m; v++)
			{
				if (visit[v]==false&&dis[v]>dis[u]+e[u][v])
				{
					dis[v] = dis[u] + e[u][v];
				}
			}
		}
		for (int i = 1; i <= n; i++)
		{
			if (dis[i]>ds)//必须在服务距离之内
			{
				mindis = -1;
				break;
			}
			if (dis[i]<mindis)
			{
				mindis = dis[i];
			}
			aver += 1.0*dis[i];
		}
		if (mindis==-1)//这里马虎写成一个=号了,找了挺久错误,不应该这样不细心
		{
			continue;
		}
		aver = aver / n;
		if (mindis>ansdis)//代码进行到这里说明在服务距离之内,在此条件下,尽可能远离民居,mindis代表了此加油站距离所有民居中的最近的那个距离
		{
			ansdis = mindis;
			ansid = index;
			ansaver = aver;
		}
		else if (mindis==ansdis&&aver<ansaver)//距离最近民居一样,平均距离小的优先。下标小的优先已经在for语句中体现了:index从n+1到n+m遍历,下标本来就是从小到大的。
		{
			ansaver = aver;
			ansid = index;
		}
	}
	if (ansid==-1)
	{
		cout << "No Solution" << endl;
	}
	else
	{
		cout << "G" << ansid-n << endl;
		printf("%.1f %.1f\n", ansdis, ansaver);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值