1131 Subway Map (30分) DFS 深度优先搜索 怪麻烦的 太美了

In the big cities, the subway systems always look so complex to the visitors. To give you some sense, the following figure shows the map of Beijing subway. Now you are supposed to help people with your computer skills! Given the starting position of your user, your task is to find the quickest way to his/her destination.

subwaymap.jpg

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 100), the number of subway lines. Then N lines follow, with the i-th (i=1,⋯,N) line describes the i-th subway line in the format:

M S[1] S[2] ... S[M]

where M (≤ 100) is the number of stops, and S[i]'s (i=1,⋯,M) are the indices of the stations (the indices are 4-digit numbers from 0000 to 9999) along the line. It is guaranteed that the stations are given in the correct order -- that is, the train travels between S[i] and S[i+1] (i=1,⋯,M−1) without any stop.

Note: It is possible to have loops, but not self-loop (no train starts from S and stops at S without passing through another station). Each station interval belongs to a unique subway line. Although the lines may cross each other at some stations (so called "transfer stations"), no station can be the conjunction of more than 5 lines.

After the description of the subway, another positive integer K (≤ 10) is given. Then K lines follow, each gives a query from your user: the two indices as the starting station and the destination, respectively.

The following figure shows the sample map.

samplemap.jpg

Note: It is guaranteed that all the stations are reachable, and all the queries consist of legal station numbers.

Output Specification:

For each query, first print in a line the minimum number of stops. Then you are supposed to show the optimal path in a friendly format as the following:

Take Line#X1 from S1 to S2.
Take Line#X2 from S2 to S3.
......

where Xi's are the line numbers and Si's are the station indices. Note: Besides the starting and ending stations, only the transfer stations shall be printed.

If the quickest path is not unique, output the one with the minimum number of transfers, which is guaranteed to be unique.

Sample Input:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
3
3011 3013
6666 2001
2004 3001

Sample Output:

2
Take Line#3 from 3011 to 3013.
10
Take Line#4 from 6666 to 1306.
Take Line#3 from 1306 to 2302.
Take Line#2 from 2302 to 2001.
6
Take Line#2 from 2004 to 1204.
Take Line#1 from 1204 to 1306.
Take Line#3 from 1306 to 3001.

 大意:给出地铁站的分布,给出起始站点和终止站点,求一条经过站点数目最少的路,如果有多条,取路径上中转站点最少的那条,然后按照要求的格式输出。

柳: 

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

const int inf = 999999;

int n,m,k,mincnt,  startstop, endstop,mintransfer,visit[10006];
vector<int> e[10006],temppath,path;
unordered_map<int, int> line;

int transfercnt(vector<int> a)
{
	int cnt = -1, preline = 0;
	for (int i = 1; i < a.size(); i++)
	{
		if (line[a[i-1]*10000+a[i]]!=preline)
		{
			cnt++;
		}
		preline = line[a[i - 1] * 10000 + a[i]];
	}
	return cnt;
}

void dfs(int node, int cnt)
{//特别注意这里的逻辑关系
	if (node==endstop&&(cnt<mincnt||(cnt==mincnt&&transfercnt(temppath)<mintransfer)))
	{
		path = temppath;
		mincnt = cnt;
		mintransfer = transfercnt(temppath);
	}
	if (node==endstop)
	{
		return;
	}
	for (int i = 0; i < e[node].size(); i++)
	{
		if (visit[e[node][i]]==0)
		{
			visit[e[node][i]] = 1;
			temppath.push_back(e[node][i]);
			dfs(e[node][i], cnt + 1);
			visit[e[node][i]] = 0;
			temppath.pop_back();
		}
	}
}

int main()
{
	//freopen("in.txt", "r", stdin);
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		int pre, temp;
		cin >> m>>pre;
		for (int j = 1; j < m; j++)
		{
			cin >> temp;
			e[temp].push_back(pre);
			e[pre].push_back(temp);
			line[pre * 10000 + temp] = line[temp * 10000 + pre] = i + 1;
			pre = temp;
		}
	}
	cin >> k;

	for (int i = 0; i < k; i++)
	{
		cin >> startstop >> endstop;
		mincnt = inf, mintransfer = inf;
		temppath.clear();
		temppath.push_back(startstop);
		visit[startstop] = 1;
		dfs(startstop, 0);
		visit[startstop] = 0;
		cout << mincnt << endl;
		int preline = 0, pretransfer = startstop;
		for (int j = 1; j < path.size(); j++)
		{
			if (line[path[j-1]*10000+path[j]]!=preline)
			{
				if (preline != 0)
				{
					printf("Take Line#%d from %04d to %04d.\n",
						preline, pretransfer, path[j-1]);
				}
				preline = line[path[j - 1] * 10000 + path[j]];
				pretransfer = path[j - 1];
			}		
		}
		printf("Take Line#%d from %04d to %04d.\n", 
			preline, pretransfer, endstop);
	}
	return 0;
}

二刷:柳:这个代码实在太美了!!!

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

const int maxn = 10006,inf=999999;
int n, m, startstop, endstop,k,cnt,mincnt,mintransfer;
unordered_map<int, int> line;
vector<int> e[maxn],path,temppath,visit(maxn);

int gettransfer(vector<int> path)
{
	int preline = 0,cnt=-1;
	for (int i = 1; i < path.size(); i++)
	{
		if (line[path[i - 1] * 10000 + path[i]] != preline)
		{
			cnt++;
		}
		preline = line[path[i - 1] * 10000 + path[i]];
	}
	return cnt;
}

void dfs(int v, int cnt)
{
	if (v==endstop&&(cnt<mincnt||(cnt==mincnt&&gettransfer(temppath)<mintransfer)))
	{
		mincnt = cnt;
		path = temppath;
	}
	if (v==endstop)
	{
		return;
	}
	for (int i = 0; i < e[v].size(); i++)
	{
		if (visit[e[v][i]]==0)
		{
			visit[e[v][i]] = 1;
			temppath.push_back(e[v][i]);
			dfs(e[v][i], cnt + 1);
			temppath.pop_back();
			visit[e[v][i]] = 0;
		}
	}
}

int main()
{
	freopen("in.txt", "r", stdin);
	cin >> n;
	for (int i = 1; i <= n; i++)
	{
		int pre, temp;
		cin >> m>>pre;
		for (int j = 1; j < m; j++)
		{
			cin >> temp;
			e[pre].push_back(temp);
			e[temp].push_back(pre);
			line[pre * 10000 + temp] = line[temp * 10000 + pre] = i;
			pre = temp;
		}
	}
	cin >> k;
	for (int i = 0; i < k; i++)
	{
		mincnt = inf, mintransfer = inf;

		cin >> startstop >> endstop;
		temppath.clear();
		visit[startstop] = 1;
		temppath.push_back(startstop);
		dfs(startstop, 0);
		visit[startstop] = 0;
		//temppath.pop_back();
		cout << mincnt << endl;

		int preline = 0,pretransfer=startstop;
		for (int j = 1; j < path.size(); j++)
		{
			if (line[path[j - 1] * 10000 + path[j]] != preline)
			{
				if (preline != 0)
				{
					printf("Take Line#%d from %04d to %04d.\n", preline, pretransfer, path[j - 1]);
				}
				preline = line[path[j - 1] * 10000 + path[j]];
				pretransfer = path[j - 1];
			}
		}
		printf("Take Line#%d from %04d to %04d.\n", preline, pretransfer, endstop);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值