1139 First Contact (30分) 模拟题 有点像并查集,但可以不用并查集的方法

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

 吾:

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
#include <unordered_map>

using namespace std;

vector<int> v[10006];

int stringToInt(string s)
{
	int i;
	if (s.length()==5)
	{
		i = stoi(s.substr(1));
	}
	else
	{
		i = stoi(s);
	}
	return i;
}

//排序小技巧  弄个struct
struct node
{
	int x, y;
};

bool cmp(node a, node b)
{
	return a.x != b.x ? a.x < b.x : a.y < b.y;
}

int main()
{
	//freopen("in.txt", "r", stdin);
	string sa, sb;
	int n, k, m, a, b;
	vector<node> ans;
	unordered_map<int, string> mp;
	unordered_map<int, bool> isfriend;
	cin >> n >> m;
	for (int i = 0; i < m; i++)
	{
		cin >> sa >> sb;
		a = stringToInt(sa);
		mp[a] = sa;
		b = stringToInt(sb);
		mp[b] = sb;
		if (sa.length() == sb.length())//因为 在同性朋友中找,所以同性的才push
		{
			v[a].push_back(b);
			v[b].push_back(a);
		}
		isfriend[a * 10000 + b] = true;	
	}
	cin >> k;
	string qa, qb;
	for (int i = 0; i < k; i++)
	{
		ans.clear();
		cin >> qa >> qb;
		a = stringToInt(qa);
		b = stringToInt(qb);
		for (int j = 0; j < v[a].size(); j++)
		{
			for (int l = 0; l < v[b].size(); l++)
			{
				if (isfriend[v[a][j]*10000+v[b][l]]==true||//true了,说明这俩人是朋友
						isfriend[v[b][l]*10000+v[a][j]]==true)
				{
					if (v[a][j] == b || v[b][l] == a)//如果这个朋友正好是喜欢的那个人,跳过,因为需要中间人
					{
						continue;
					}
					if (mp[v[a][j]].length()!=mp[a].length()||
							mp[v[b][l]].length()!=mp[b].length())
					{//区分性别,长度不同,说明性别不同,因为多了个"-";因为是在同性朋友中找能共同朋友的人,要和查询的人的性别一致
						continue;
					}
					ans.push_back({ v[a][j],v[b][l] });
				}
			}
		}
		cout << ans.size() << endl;
		sort(ans.begin(), ans.end(), cmp);
		if (!ans.empty())
		{
			printf("%04d %04d\n", ans[0].x, ans[0].y);
		}
		
		for (int j = 1; j < ans.size(); j++)
		{
			printf("%04d %04d\n", ans[j].x, ans[j].y);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
C语言是一种广泛使用的编程语言,它具有高效、灵活、可移植性强等特点,被广泛应用于操作系统、嵌入式系统、数据库、编译器等领域的开发。C语言的基本语法包括变量、数据类型、运算符、控制结构(如if语句、循环语句等)、函数、指针等。在编写C程序时,需要注意变量的声明和定义、指针的使用、内存的配与释放等问题。C语言中常用的数据结构包括: 1. 数组:一种存储同类型数据的结构,可以进行索引访问和修改。 2. 链表:一种存储不同类型数据的结构,每个节点包含数据和指向下一个节点的指针。 3. 栈:一种后进先出(LIFO)的数据结构,可以通过压入(push)和弹出(pop)操作进行数据的存储和取出。 4. 队列:一种先进先出(FIFO)的数据结构,可以通过入队(enqueue)和出队(dequeue)操作进行数据的存储和取出。 5. 树:一种存储具有父子关系的数据结构,可以通过中序遍历、前序遍历和后序遍历等方式进行数据的访问和修改。 6. 图:一种存储具有节点和边关系的数据结构,可以通过广度优先搜索、深度优先搜索等方式进行数据的访问和修改。 这些数据结构在C语言中都有相应的实现方式,可以应用于各种不同的场景。C语言中的各种数据结构都有其优缺点,下面列举一些常见的数据结构的优缺点: 数组: 优点:访问和修改元素的速度非常快,适用于需要频繁读取和修改数据的场合。 缺点:数组的长度是固定的,不适合存储大小不固定的动态数据,另外数组在内存中是连续配的,当数组较大时可能会导致内存碎片化。 链表: 优点:可以方便地插入和删除元素,适用于需要频繁插入和删除数据的场合。 缺点:访问和修改元素的速度相对较慢,因为需要遍历链表找到指定的节点。 栈: 优点:后进先出(LIFO)的特性使得栈在处理递归和括号匹配等问题时非常方便。 缺点:栈的空间有限,当数据量较大时可能会导致栈溢出。 队列: 优点:先进先出(FIFO)的特性使得

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值