1052 Linked List Sorting (25 分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer keyand a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<10​5​​) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10​5​​,10​5​​], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1
#include <iostream>
#include <vector>
#include <iomanip>
#include <algorithm>

using namespace std;

#define maxn 100001


struct node
{
	int address, next,data;
	bool flag;
	node()
	{	
		flag = false;
	}
}Node[maxn];

bool cmp(node n1, node n2)
{
	if (n1.flag==false||n2.flag==false)
	{
		return n1.flag > n2.flag;
	}
	else
	{
		return n1.data < n2.data;
	}

    //也可以这样写
	//return n1.flag==false||n2.flag==false?n1.flag>n2.flag:n1.data<n2.data;
}

int main()
{
	//freopen("in.txt","r",stdin);
	
	int n,first_address;
	cin >> n >> first_address;
	for (int i = 0; i < n; i++)
	{
		int a, b, c;
		cin >>a>>b>>c;
		Node[a].address = a;
		Node[a].data = b;
		Node[a].next = c;
	}


	int cnt = 0,i=0;
	//遍历链表找到有效的点  即在链表上的点   将在链表和不在链表的点区别开
	for (i = first_address; i!=-1 ; i=Node[i].next)
	{
		if (Node[i].flag==false)
		{
			Node[i].flag = true;
		}		
		cnt++; //统计有效节点 即在链表上的节点
	}


	
	
	if (cnt==0) //特判  先特判再排序  如果没有节点直接结束啦 就不用排序了 
	{
		cout << "0 -1";
	}
	else
	{
		sort(Node, Node + maxn, cmp); //先排序把在链表上的点 全都弄到最左边 cmp两级排序
		cout << cnt << " ";
		printf("%05d\n", Node[0].address);
		for (int i = 0; i < cnt; i++)
		{
			printf("%05d ", Node[i].address);
			//cout << right << setw(5) << setfill('0') << Node[i].address << " ";
			cout << left << Node[i].data << " ";
			if (i!=cnt-1)
			{
				printf("%05d\n", Node[i + 1].address);  //用cout会“运行超时”  试验过 程序只有printf和cout差别时  cout会超时
				//cout << right << setw(5) << setfill('0') << Node[i+1].address <<endl;
			}
			else
			{
				cout << "-1" << endl;
			}
		}
	}
	
	/*int j = 0;
	while (j<cnt)
	{
		if (j !=cnt-1)
		{
			cout << right << setw(5) << setfill('0') << Node[j].address << " ";
			cout << left << Node[j].data << " ";
			cout << right << setw(5) << setfill('0') << Node[j +1].address << endl;
		}
		else
		{
			cout << right << setw(5) << setfill('0') << Node[j].address << " ";
			cout << left << Node[j].data << " ";
			cout << "-1" << endl;
		}
		j++;
	}*/
	
	
	//fclose(stdin);
	return 0;
}

 

请参考我给出的代码框架,实现对EMPLOYEE结构体为数据的双向链表的排序算法,要求按照按employeeId升序排列 typedef struct linkNode { void* data; //使用空指针使得NODE适配多种数据结构 struct linkNode* preNode; struct linkNode* nextNode; }LINKED_NODE; /*Define the struct of double linked list.*/ typedef struct { LINKED_NODE* head; LINKED_NODE* tail; size_t size; }DOUBLE_LINK_LIST; typedef struct { int employeeId; char name[20]; char ipAddress[30]; char seatNumber[20]; char group[10]; } EMPLOYEE; DOUBLE_LINK_LIST* createDoubleLinkedList() { DOUBLE_LINK_LIST* newList = (DOUBLE_LINK_LIST*)malloc(sizeof(DOUBLE_LINK_LIST)); newList->head = NULL; newList->tail = NULL; newList->size = 0; return newList; } void destroyDoubleLinkedList(DOUBLE_LINK_LIST* list) {} /*Add a new node before the head.*/ void insertHead(DOUBLE_LINK_LIST* list, void* data) // void执政适配其他data类型? {} /*Add a new node after tail.*/ void insertTail(DOUBLE_LINK_LIST* list, void* data) // 如何适配其他data类型? {} /*Insert a new node.*/ void insertNode(DOUBLE_LINK_LIST* list, void* data,int index) // 如何适配其他data类型? {} void deleteHead(DOUBLE_LINK_LIST* list) {} void deleteTail(DOUBLE_LINK_LIST* list) {} void deleteNode(DOUBLE_LINK_LIST* list, int index) {} LINKED_NODE* getNode(DOUBLE_LINK_LIST* list, int index) {} /* 遍历链表,对每个节点执行指定操作*/ void traverseList(DOUBLE_LINK_LIST* list, void (*callback)(void*)) { LINKED_NODE* currentNode = list->head; while (currentNode != NULL) { callback(currentNode->data); currentNode = currentNode->nextNode; } } void printEmployee(void* data) {}
最新发布
07-25
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值