1017 Queueing at Bank (25 分)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2
#include <iostream>	
#include <vector>	
#include <algorithm>	

using namespace std;

struct customer
{
	int come, time;
};

bool cmp(customer c1, customer c2)
{
	return c1.come < c2.come;
}

int main()
{
	//freopen("in.txt", "r", stdin);
	int n, k, hour, minute, second, index = 1, lateCount = 0;
	cin >> n >> k;
	vector<int> waitTime(n + 1, 0);
	vector<customer> custome(n + 1);
	for (int i = 1; i <= n; i++)
	{
		int temptime = 0;
		scanf("%d:%d:%d %d", &hour, &minute, &second, &temptime);
		int comeTime = hour * 60 * 60 + minute * 60 + second;
		custome[i].come = comeTime;
		custome[i].time = temptime * 60;
		if (comeTime > 61200)//太晚了  银行关门了  这个人不用考虑 所以最后除的时候减去来晚的人
		{
			lateCount++;
			continue;
		}
	}
	sort(custome.begin(), custome.end(), cmp);
	//所有窗口的初始化 都是从8点开始
	vector<int> window(k + 1, 28800);//save endtime
	


	while (index <= n)
	{
		int minEndtime = window[1], tempWindow = 1;
		for (int i = 2; i <= k; i++)
		{
			if (minEndtime > window[i])
			{
				minEndtime = window[i];
				tempWindow = i;
			}
		}
		if (custome[index].come < window[tempWindow])  //早到需要等和到的时候正好有空窗口不需要等两种情况
		{
			waitTime[index] += (window[tempWindow] - custome[index].come);
			window[tempWindow] += custome[index].time;
		}
		else
		{
			window[tempWindow] = custome[index].come + custome[index].time;
		}
		
		index++;
	}

	double totalWaitTime = 0.0;
	for (int i = 1; i <= n; i++)
	{
		totalWaitTime += waitTime[i];
	}
	if (n - lateCount == 0)
	{
		cout << "0.0\n" << endl;
	}
	else
	{
		printf("%.1f\n", totalWaitTime / (n - lateCount) / 60);
	}

	//fclose(stdin);
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Queueing theory is a mathematical study of waiting lines or queues that arise in various real-life scenarios, such as customer service, traffic congestion, hospital emergency rooms, and telecommunications networks. Basic queueing theory involves the following concepts: 1. Arrival Process: This is the process of customers arriving at the queue. The arrival process can be modeled using different distributions, such as Poisson or exponential. 2. Service Process: This is the process of serving customers in the queue. The service process can also be modeled using different distributions, such as Poisson or exponential. 3. Queue Length: This is the number of customers waiting in the queue at any given time. 4. Queue Occupancy: This is the proportion of time that the server is busy serving customers. 5. System Capacity: This is the maximum number of customers that the system can handle at any given time. 6. Utilization: This is the proportion of time that the server is busy serving customers compared to the total time. 7. Waiting Time: This is the time that a customer spends waiting in the queue before being served. 8. Service Time: This is the time that a customer spends being served by the server. 9. Queueing Models: There are different queueing models that can be used to analyze queueing systems, such as the M/M/1 model, M/M/c model, M/G/1 model, and M/D/1 model. 10. Performance Measures: Different performance measures can be used to evaluate queueing systems, such as average waiting time, average queue length, and system throughput.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值