HDU 3549 最大流 水题

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 11558    Accepted Submission(s): 5471


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
  
  
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
  
  
Case 1: 1 Case 2: 2
 

Author
HyperHexagon
 

Source
 


/************************************************

Desiner:hl
time:2015/11/02
Exe.Time:639MS
Exe.Memory:3184K



题解:裸最大流。做做练手速 
不过还是小心。我一开始用了sap(S,V,V+1)导致答案出不来。 

************************************************/

#include <iostream>    
#include <algorithm>    
#include <cstring>    
#include <string>    
#include <cstdio>    
#include <cmath>      
    
using namespace std;    
const int MAXN = 100010 ; //点数最大值      
const int MAXM = 400010 ; //边数最大值      
const int INF = 0x3f3f3f3f;      
  
int S,V,N,M;  

 
struct Edge{      
    int to,next,cap,flow;      
}edge[MAXM];//注意是MAXM      
int tol;      
int head[MAXN];      
int gap[MAXN],dep[MAXN],pre[MAXN],cur[MAXN];       

    
void init(){      
    tol = 0;      
    memset(head,-1,sizeof(head));      
}       
    
void addedge(int u,int v,int w,int rw=0){      
    edge[tol].to = v;      
    edge[tol].cap = w;      
    edge[tol].next = head[u];      
    edge[tol].flow = 0;      
    head[u] = tol++;      
    edge[tol].to = u;      
    edge[tol].cap = rw;      
    edge[tol].next = head[v];      
    edge[tol].flow = 0;      
    head[v] = tol++;      
}      
  //最大流开始     
int sap(int start,int end,int N){      
    memset(gap,0,sizeof(gap));      
    memset(dep,0,sizeof(dep));      
    memcpy(cur,head,sizeof(head));      
    int u = start;      
    pre[u] = -1;      
    gap[0] = N;      
    int ans = 0;      
    while(dep[start] < N){      
        if(u==end){      
            int Min = INF;      
            for(int i=pre[u];i!= -1; i=pre[edge[i^1].to])      
                if(Min > edge[i].cap - edge[i].flow)      
                    Min = edge[i].cap - edge[i].flow;      
                          
            for(int i=pre[u];i!=-1;i=pre[edge[i^1].to]){      
                edge[i].flow += Min;      
                edge[i^1].flow -=Min;      
            }      
            u=start;      
            ans +=Min;      
            continue;      
        }      
        bool flag = false;      
        int v;      
        for(int i= cur[u];i!=-1;i=edge[i].next){      
            v=edge[i].to;      
            if(edge[i].cap-edge[i].flow&&dep[v]+1==dep[u]){      
                flag=true;      
                cur[u]=pre[v]=i;      
                break;      
            }      
        }      
        if(flag){      
            u=v;      
            continue;      
        }      
        int Min = N;      
        for(int i=head[u];i!= -1;i=edge[i].next)      
            if(edge[i].cap-edge[i].flow&&dep[edge[i].to]<Min){      
                Min=dep[edge[i].to];      
                cur[u] = i;      
            }      
        gap[dep[u]]--;      
        if(!gap[dep[u]]) return ans;      
        dep[u] = Min +1;      
        gap[dep[u]]++;      
        if(u!=start) u = edge[pre[u]^1].to;      
    }      
    return ans;      
}      
//最大流结束     
  
int build(){  
    int i,j,k,l,m,n,st,en,va;  
    init();  
    for(i=1;i<=M;i++){  
    	scanf("%d%d%d",&st,&en,&va);
    	addedge(st,en,va);
    } 

    int orz=sap(S,V,V);  
    return orz;  
}  
int main(){     

	int T;
    int m,n,q,p;      
    int i,j,k,a,b,c; 
	int pisum;  
	scanf("%d",&T);
    for(int cas=1;cas<=T;cas++){
    	scanf("%d%d",&N,&M);  
		S=1;
		V=N;		
    	printf("Case %d: %d\n",cas,build());
    }	 
    return 0;  
}      


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值