浅谈栈的使用:模拟

栈的存储方式是后进先出,怎么理解后进先出呢?即数据以1 2 3的形式进入,3 2 1的形式输出。正着进倒着出就是栈,所以我们就可以用栈来模拟这种过程。以一道例题来讲

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes
题目以1,2,3,,,n的顺序入栈,问你出栈的顺序合不合法。 我们就可以用栈来模拟这一过程我们以5为例探究进出栈的方式:

首先我们必须以1 2 3 4 5的顺序把值存入栈,栈内一但有了值就可输出即我们可以有如下过程

一先把1 2 放入栈

二从栈顶取出2

三把3 4 5放入栈

四依次取出就可以得到顺序2 5 4 3 1 。如果我们要得到这样顺序就要思考何时入栈何时出栈,只需要考虑清楚这两点就可以很好的做出题目首先无论如何先把1放入栈,接下来判断我要的序列的第一个数是否是1 如果是直接取出,不是的话我们就把2存入。判断栈顶的数即2,是否是需要数列的第一个值,依次进行直到找到栈顶等于所需数列第一个值后取出,然后判断当前栈顶是否等于第二个数,相等取出不相等存入。一直进行当没有数可以存入栈且不能取出时判断栈是否为空。若栈空即模拟成功,若不为空即模拟失败。

因此可以写出代码:

#include<iostream>
#include<stack>

using namespace std;

int main()
{
    int n;
    while(cin >>n && n != 0){
        int tar[n + 3];
        stack<int> s_s;
        while(cin >> tar[1] && tar[1]){
            for(int i = 2;i <= n;++i){
                cin >> tar[i];
            }
            bool jd = 1;
            for(int i = 1,j = 1;j <= n;){
                if(!s_s.empty() && s_s.top() == tar[j]){
                    s_s.pop();
                    j++;
                }
                else if(i <= n)
                    s_s.push(i++);
                else{
                    jd = 0;
                    break;
                }
            }
            if(jd)
                cout << "Yes" <<endl;
            else
                cout << "No" << endl;

        }
        cout << endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值